File or Directory Not Found Issue

Another newbie question…

I have successfully installed Debian on my SD card and can boot my BBB from the card. I inserted a USB stick that contains the Oracle JRE on it and was able to mount the stick as /media/usb. When I cd into the bin directory and run ./java -version I get the proper information. So I copied the entire JRE installation into the /opt directory on the SD card and set the PATH to include the jre/bin directory. However, when I execute the java -version command I get File or Directory not found. Anyone have any thoughts on how to get this working so that I don’t have to run it from the USB?

  • Tim

You have to enter the full path to an executable if it’s in the /opt directory. If it was in /bin, /usr/bin etc it would be executable by invoking a program name

Here is what I get when I tried the full path:

root@arm:~# /opt/java/ejre1.7.0_21/bin/java -version
-su: /opt/java/ejre1.7.0_21/bin/java: No such file or directory

Is your host running the soft float abi OS or is it hard float abi. From the looks of the message I would think its hard float machine because the bits you have are only soft float based. Please look for 8 JDK ea arm bits. They are hard float.


Do you know which version of the JDK I should be downloading? I went to the Oracle embedded download page and they list the following available:

ARMv6/7 Linux - Headless EABI, VFP, SoftFP ABI, Little Endian1 | 31 MB | Downloadejre-7u21-fcs-b11-linux-arm-vfp-client_headless-04_apr_2013.tar.gz |

My OS is: Debian Linux arm 3.8.13-bone20 #1 SMP Wed May 29 03:11:01 UTC 2013 armv7l GNU/Linux

$ ls -la /opt/java/ejre1.7.0_21/bin/java

Was this solved? I’m getting the same error