Flashing NAND "Usage: nand - NAND sub-system" ?

Hi all,

I recently tried to upgrade (purge and reflash) a new x-loader on my
rev b5 BeagleBoard and failed miserably. Nothing comes on the screen
or via serial when I turn on the BeagleBoard.

I can; however, hold the user button to boot from the SD card. I tried
flashing a new x-loader and u-boot via [1] and [2] and both result
with nothing happening from my BeagleBoard when I power it on. I'm not
sure why those two websites disagree slightly in the procedure of
flashing x-loader, 80200000 vs 80000000.

I've looked over [3], but it doesn't seem to mention anything about
flashing onto the NAND - just how to boot from SD card to erase the
NAND, which I can do fine.

One thing that I've noticed when following both procedures is that
when I type "nand unlock" or "nand ecc hw" (without the quotes) into
u-boot via serial, it replies with "Usage: nand - NAND sub-system".
That doesn't seem like the correct response that I should get from
either command.

Anyways, anyone have any ideas on how to put a new x-loader and
working u-boot back on my NAND flash? The whole reason for doing this
was because I could not change the environment variables for the u-
boot on the SD card (latest version from Angstrom demo). I could set
and save the environment variables, but it didn't actually use them (I
could tell because it wasn't changing to the resolution that I set and
used the default). Then when I reset the BeagleBoard, the environment
variables would be erased. So I assumed that you could only alter the
environment variables of a u-boot on the NAND and therefore tried to
upgrade from the old version 1.3.3 to the newest. In the process, I
killed the BeagleBoard's NAND.

- Dan

[1] http://code.google.com/p/beagleboard/wiki/HowToGetAngstromRunning
[2] http://elinux.org/BeagleBoardNAND
[3] http://elinux.org/BeagleBoardRecovery

just one little thing: You are getting the correct response for nand
unlock -> coz you dont need to run it on beagle..

Nishanth Menon

Also, newer U-boot versions use "nandecc hw" (no space between nand and ecc), instead of "nand ecc hw". I'd give that a try.


"nandecc hw" for x-loader and "nandecc sw" for u-boot did the trick!