Flashing Ubuntu 12.04 To eMMC

Been trying to flash the Ubuntu 12.04 image from the uSD card to the eMMC on the BBB. Everytime I try to do this a permission denied error appears when when prepending sudo to the command. Tried to flash the eMMC using the following commands:

xzcat ubuntu-precise-12.04.3-armhf-3.8.13-bone30.img.xz | dd of=/dev/mmcblk1 bs=1M

xz -cd ubuntu-precise-12.04.3-armhf-3.8.13-bone30.img.xz > /dev/mmcblk1

Would be much easier if there was a eMMC flash image for Ubuntu 12.04 like there is for 13.04. Why does Ubuntu 12.04 not have a eMMC flash image? The version of Ubuntu being flashed to the eMMC must be 12.04 for stability reasons.

“sudo su”
and then issue the commands…

"stability" you realize the arm developers at ubuntu ignore 12.04 once
12.10 hits right?


This is why a rolling release distro is much easier in the long run to
maintain and use at least that is how I feel on the subject. It always
gets the dev's love, not to be quickly abandoned because version X is
now time to be created. Leave the X.X version scheme to software.

I agree, hence i run Debian unstable.. 'jessie', and i have images
posted for that too..