Following the "Customize BeagleV-Fire Cape" Demo

I have been following the Customize BeagleV-Fire Cape Demo and it has been very helpful. Thank you for the work that has gone into it so far.

I am running into a few problems following along:

  1. Using the gateware/main branch, my device trees aren’t working like I would expect. If I load a shipping bitfile such as “default”, “robotics” or BVF-0.4.0-27-g7078de9 the devices show up in /sys/ like I would expect i.e. with pwmchipx```.

    beagle@BeagleV:~$ find /sys/class -iname "*pwm*" 2>/dev/null
    /sys/class/pwm
    /sys/class/pwm/pwmchip32
    /sys/class/pwm/pwmchip0
    /sys/class/pwm/pwmchip16
    beagle@BeagleV:/sys/bus/i2c/devices$ ls -al
    total 0
    drwxr-xr-x 2 root root 0 Sep 19 16:50 .
    drwxr-xr-x 4 root root 0 Sep 19 16:50 ..
    lrwxrwxrwx 1 root root 0 Sep 19 16:50 1-0010 -> ../../../devices/platform/soc/2010b000.i2c/i2c-1/1-0010
    lrwxrwxrwx 1 root root 0 Sep 19 16:50 1-0050 -> ../../../devices/platform/soc/2010b000.i2c/i2c-1/1-0050
    lrwxrwxrwx 1 root root 0 Sep 19 16:50 i2c-0 -> ../../../devices/platform/soc/2010a000.i2c/i2c-0
    lrwxrwxrwx 1 root root 0 Sep 19 16:50 i2c-1 -> ../../../devices/platform/soc/2010b000.i2c/i2c-1
    

    If I build the same “default” or “robotics” cape with no changes using the build-bitstream.py script the drivers don’t load and I see empty folders.

    beagle@BeagleV:~$ cd /sys/class/pwm
    beagle@BeagleV:/sys/class/pwm$ ls -al
    total 0
    drwxr-xr-x  2 root root 0 Sep 19 16:50 .
    drwxr-xr-x 52 root root 0 Sep 19 16:50 ..
    

    I double checked the device tree and it does not show the overlays directory I expect.

    beagle@BeagleV:/proc/device-tree/chosen$ ls
    boot-hartid  name  stdout-path
    
  2. To fix that issue I was thinking that I need to build with the CI pipeline as it suggests in a later step. To do that I need to fork the Gateware repo. Unfortunately, the “Fork” option for the Gateware repo is greyed out and disabled.

    Should it be available to all users? Or should I request access?

    I can click on the number beside the “Fork” button and a new window with a new green “Fork” button shows up. I can add my details, customize the repo name, etc but when I click “Fork Project” it errors out with an unhelpful description.

Thank you again for the help.

1 Like

What’s your account name, new users have to be first enabled… To prevent ci/git spam…

NM, found your account, you are now enabled…

Regards,

1 Like

Thank you for giving me access. I was able to fork the repository and the CI pipeline seems to work really well.

After further investigation, I think my other issue was due to not having device tree compiler installed locally.

1 Like