FYI, netbeans 20 and Ubuntu 22.04 installation issue

For those that cannot get the C/C++ tools plugin into install

$sudo apt install openjdk-8-jre

That version 8 package is unfortunately not available in Debian 12.

You will also need the default installed or openjdk-17

This might be the last of an extremely good remote building tool, it has not been maintained since 2017 and reading between the lines on the netbeans github the future of the plugin is not looking good.