gconvert.c:48:2: error: #error GNU libiconv not in use but included

Hi,

When building the openembedded angstrom distribution for latest dev branch, I have encountered an error with building the glib packages.
glib-2.0-native_2.22.1.bb was failing with oe_runmake. I fould the error reported in the log was as follows

gconvert.c:48:2: error: #error GNU libiconv not in use but included

To solve this problem following is the solution

add the following line in the recipe file

EXTRA_OECONF = “-with-libiconv=gnu”

This would solve the error. This is for benefit of those who are using OE for their builds for Angstrom distribution

Regards,
Prem