gdbserver won't install (debian 8.4)


I’m trying to run ./gdbserver on the beaglebone black but I get:
‘No such file or directory’

The BBB is flashed with 8.4 (cat /etc/debian_version)

According to the excellent Derek Molloy videos, it should come pre-installed with debian:

Unfortunately, even trying to install it manually doesn’t work:
root@beaglebone:~# apt-get install gdbserver

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package gdbserver is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘gdbserver’ has no installation candidate


The /etc/apt/sources.list file looks like:

deb jessie main contrib non-free
deb jessie-updates main contrib non-free

deb jessie/updates main contrib non-free

deb jessie main

deb [arch=armhf] jessie main

Is there something I need to install first?


No . . .gdb-server does not come preinstalled in Debian.

sudo apt-get update
sudo apt-get install gdbserver


william@beaglebone:~$ dpkg -l | grep gdbserver

william@beaglebone:~$ sudo apt-get update
. . .
william@beaglebone:~$ apt-cache search gdbserver
gdbserver - GNU Debugger (remote server)
gdbserver-c6x - TI gdb-server for Keystone 2 devices.

Thanks, I get the same install error… However, there’s a bunch of error messages* during apt-get update that weren’t there when before (when I originally ran it after upgrading the flash from debian 7 to 8).

By the way, I tried posting this on the forum, but couldn’t find it… How did you see this?!



$ sudo apt-get update

$ sudo apt-get upgrade

You’re using an older APT list file and hopefully apt-get upgrade will fix that. If not, then probably Robert will have to tell you what he’s changed the list to most recently.

By the way, When you’re running as root. You do not have to use sudo.

So, it works. Judging from your output, you may have lost internet in the middle of that command, or your providers DNS for the IP addresses listed in your output went south. It happens . . .

william@beaglebone:~$ sudo apt-get install gdbserver
[sudo] password for william:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 28 not upgraded.
Need to get 203 kB of archives.
After this operation, 347 kB of additional disk space will be used.
Get:1 jessie/main gdbserver armhf 7.7.1+dfsg-5 [203 kB]
Fetched 203 kB in 1s (163 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = “en_US.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package gdbserver.
(Reading database … 40100 files and directories currently installed.)
Preparing to unpack …/gdbserver_7.7.1+dfsg-5_armhf.deb …
Unpacking gdbserver (7.7.1+dfsg-5) …
Setting up gdbserver (7.7.1+dfsg-5) …