Getting IP address of BBB on ubuntu terminal


i am new to beagle bone black board. just after getting new board i connected that board to my PC using USB cable and checked it is showing BEAGLE BONE like mass storage drive on system(linux ubuntu), i clicked and entered in to drive and got one START.HMT file clicked on it, it went to website and showed next step install drivers…

i downloaded the file and run it by using chmod + x(for permission) , sudo command , it completed…

i got 73-beagle bone.rules file is created in /etc/udev/rules.d/… after this i concluded drivers are installed properly…

i am trying to get ip address of BBB , but not able to get?? please suggest me what is problem:

acufore@acufore-H110M-S2:~$ cd /etc/udev/rules.d/
acufore@acufore-H110M-S2:/etc/udev/rules.d$ ls
acufore@acufore-H110M-S2:/etc/udev/rules.d$ cd
acufore@acufore-H110M-S2:~$ ifconfig
enp2s0 Link encap:Ethernet HWaddr e0:d5:5e:11:5d:65
inet addr: Bcast: Mask:
inet6 addr: fe80::4508:cbb4:d574:e0c1/64 Scope:Link
RX packets:30922 errors:0 dropped:0 overruns:0 frame:0
TX packets:13579 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:16593168 (16.5 MB) TX bytes:1669767 (1.6 MB)

enx3403de92aa91 Link encap:Ethernet HWaddr 34:03:de:92:aa:91
RX packets:41 errors:3 dropped:0 overruns:0 frame:3
TX packets:2 errors:58 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10411 (10.4 KB) TX bytes:520 (520.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:3169 errors:0 dropped:0 overruns:0 frame:0
TX packets:3169 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:324659 (324.6 KB) TX bytes:324659 (324.6 KB)

acufore@acufore-H110M-S2:~$ ^C

like this i am getting how can i proceed for next…?

Hi Megha,

Hi tarmo,

i am using a PC with Linux Ubuntu and version is 16.04LTS (64-bit) Ubuntu as a native operating system.

As u suggested i used tail -n 100 /var/log/syslog in to command line(terminal). i got much data not able to understand and i stored the data in to one file please check it i am attaching the same data…

one more thing u told about the local LAN can u explain it once??

abc.txt (14.1 KB)

OK. I have no experience using Ubuntu 16.04LTS, but I’d assume it contains all necessary drivers for BBB out of the box.

The 2 minute log snippet does not contain anything which I would recognize as a BBB being plugged into USB. Perhaps you did it earlier?

Anyway, your computer appears to try getting an IP from the BBB-s DHCP server, but there’s no response. No idea why. Usually my computer gets a or (actually both, on two separate virtual interfaces) address from the BBB (as described in

The BBB has an Ethernet port. Connect it to your LAN (a router with a DHCP server and other standard services is required, obviously). Then you can connect to it from the same LAN. It should respond to name “beaglebone.local” by default. If this name doesn’t resolve then install avahi packages in Ubuntu. Then use your favourite ssh client to connect. Not much more to explain there.


Thanks for reply. for second option -connecting LAN cable to BBB .

i connected LAN cable from router with DHCP server, where i can see :beaglebone.local…

can u explain the basic connection :
i followed like ,

1.connected board(BBB) to PC using USB cable

  1. router with DHCP server
  2. one LAN cable from the router to board ethernet port

Well, there's nothing to "see" as such. Hopefully the BBB is now reachable via your local network. Your next steps depend on what are you planning to do with it, and this only you know. I assumed you wanted to log into it via ssh and hack away.

You can perform some basic network diagnostics using your PC (it must be connected to the same LAN, obviously).

To check if name resolution works (returns the IPv4 or IPv6 address of the BBB):
$ avahi-resolve -n beaglebone.local

To check if the BBB is reachable from your computer
$ ping beaglebone.local

yes , you are true i am going to login to the board using ssh command and trying with one simple hello world program.
once that is fine means i am going to load new Debian image in to board.after that same steps as earlier


I tried by connecting LAN cable from router to board Ethernet port, but for ping command i am getting :

acufore@acufore-H110M-S2:~$ ping beaglebone.local
ping: unknown host beaglebone.local

acufore@acufore-H110M-S2:~$ avahi-resolve -n beaglebone.local
Failed to resolve host name ‘beaglebone.local’: Timeout reached

please help me resolve…

I checked in to network settings, it is showing 2 connections…

one is system network connection-which is connected and providing ip address.
second connection for BBB - it is showing disconnected…

why it is showing disconnected?? anything i am missing here?

Your computer can't reach the beaglebone. I'm out of simple advice. Assuming your LAN setup is OK, it's rather suspicious that neither USB nor Ethernet gives you access to it.

The USB connection also creates a virtual serial port through which a serial console is available (which is nearly is as good as an ssh connection). On my machine it appears as device /dev/ttyACM0. I use it by installing the package "screen" and running:

$ screen /dev/ttyACM0 115200

Pressing Enter causes a login prompt to appear, where you can log in using the default credentials (debian/debian, IIRC). If this doesn't work, I would try re-flashing the board. Follow the instructions here:

Note that you're debugging it blindly which makes everything more difficult. If you attach a USB-Serial adapter to the debug header, you'll get the bootloader debug output and a serial console. If you don't have one at hand, search aliexpress for "FTDI USB to TTL" and get the first thing that pops up.


using LAN cable to Ethernet it is working fine… i am able to login to board.
with old image on board using ssh and ip address i logged in it is showing root@beaglebone…

I flashed the board with new Debian image, here i am using login user as Debian and password as temppwd, here i tried with LED blinking code