Gitlab CI/CD woes

Trying to follow along with the demo instructions here:

I have forked the Gateware repository and made a small change to it. So far, so good.
Now I check the CI/CD Pipelines tab and I can see that the job is stuck.
Nothing about that in the instructions, so Gitlab tells me it’s because it can’t find any runners…

Ok, lets try to enable the shared runners and see if that works.
Delete the stuck pipeline and run it again…

Bleh! The build step fails almost instantaneous with:

I am getting the feeling it’s because the runner can’t clone my repository,
but I have no idea why and yes, it’s public.
Again, nothing in the documentation says anything about this, so I’m kinda stuck.

Feels like it’s something obvious, but again, not really.

Any hints would be greatly appreciated.

Looks at build logs, why is every ci failing… (figures the day i was away from home, let’s try rebooting everything…)

@jkridner i’m seeing a lot of fun stuff going on:

Created fresh repository.
error: RPC failed; curl 92 HTTP/2 stream 5 was not closed cleanly: INTERNAL_ERROR (err 2)
error: 377 bytes of body are still expected
fetch-pack: unexpected disconnect while reading sideband packet
fatal: early EOF
fatal: fetch-pack: invalid index-pack output


Indeed, Murphy strikes again.

I don’t know if it’s something new because I have not used Gitlab until now,
but it wanted me to add an SSH public key to my user to be able to pull / push, so I did.
Before adding the key, I got pretty much the same error from VS Code.

Do all the runners need our public SSH keys all of a sudden?

Hang on, that makes no sense at all. Please ignore! :face_with_spiral_eyes:

Just out of curiosity, I tried a new pipeline run today; sadly the error remains… :worried:

It’s gotta be some weird permissions problem, but what?

Until this gets resolved, does anyone have a recipe for loading a custom .dtbo on boot?

This Sunday, I had problems with the CI and generally trying to clone though https while the same repo cloned fine through ssh. I assume the CI is failing because of the cloning of the HSS, which is done using https.

It’s internal, something in gitlab broke, i’m seeing an endless log of ‘fails’ from all the daily builds.

Edit: 20240528: @jkridner found the server was out of space, he bumped it, i see lots of green builds now…


I can confirm that my Gateware build just succeded as well. Awesome! :smiling_face: :+1:

1 Like