Hello, I’m working with a Beagleboard xm.

I’ve installed Ubuntu 11.10 with kernerl 3.2.7-x5

I’m trying to ‘turn on’ and ‘turn off’ the pin 3 of the expansion connector, it corresponds to gpio_139

I wrote the following commands

As supersuer:

echo 139 > /sys/class/gpio/export

cd /sys/class/gpio/gpio139/

echo “high” > direction

but the pin doesn’t “turn on”, somebody has some idea?

Thanks in advance.

You need to echo “out” into the file direction, and “1” or “0” into “value” and check whether the pin is actually muxed in the corrected mode, the default mode on the beaglebone would be mode 7 for gpio, but I think the beagleboard is somewhat different. I do not even know whether pins can be changed at runtime.

Somewhere in /sys/kernel/debug or /sys/debug/kernel are files which help you evaluate the current settings (on the beaglebone, again it might be different on the beagleboard)


2012/3/19 aldo nuñez <>