GPS Overlay not working on Beaglebone Black 4.1.12-ti-r29 Ubuntu 15.04 and Debian 8.2 VM

I am hoping that someone might be able to help me out on this one. I recently updated my Beaglebone Black Image as listed below in the hopes of running a script that would allow me to test the i/p and o/p’s on my BBB. Unfortunately although the code compiles and there does not appear to be any issues there the GPIO port to be updated simply does not take. I highlighted the problem in yellow. Any help or insight into this would really be appreciated. Thanks in advance.

GPS Overlay not working on Beaglebone Black 4.1.12-ti-r29 Ubuntu 15.04 and Debian 8.2 VM

Linux beaglebone 4.1.12-ti-r29 #1 SMP PREEMPT Mon Nov 9 22:46:19 UTC 2015 armv7l GNU/Linux

BeagleBoard.org Debian Image 2015-11-12

/*

I am hoping that someone might be able to help me out on this one. I
recently updated my Beaglebone Black Image as listed below in the hopes of
running a script that would allow me to test the i/p and o/p's on my BBB.
Unfortunately although the code compiles and there does not appear to be
any issues there the GPIO port to be updated simply does not take. I
highlighted the problem in yellow. Any help or insight into this would
really be appreciated. Thanks in advance.

GPS Overlay not working on Beaglebone Black 4.1.12-ti-r29 Ubuntu 15.04 and
Debian 8.2 VM

Linux beaglebone 4.1.12-ti-r29 #1 SMP PREEMPT Mon Nov 9 22:46:19 UTC 2015
armv7l GNU/Linux

BeagleBoard.org Debian Image 2015-11-12

/*

* Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/

*

* This program is free software; you can redistribute it and/or modify

* it under the terms of the GNU General Purpose License Version 2 as

* published by the Free Software Foundation

*

* Original from:
github.com/jadonk/validation-scripts/blob/master/test-capemgr/

*

* Modified by Derek Molloy for the example on www.derekmolloy.ie

* that maps GPIO pins for the example

*/

/dts-v1/;

/plugin/;

/{

compatible = "ti,beaglebone", "ti,beaglebone-black";

part-number = "DM-GPIO-Test";

version = "00A0";

fragment@0 {

target = <&am33xx_pinmux>;

__overlay__ {

pinctrl_test: DM_GPIO_Test_Pins {

pinctrl-single,pins = <

0x078 0x07 /* P9_12 60 OUTPUT MODE7 - The LED Output */

0x184 0x2f /* P9_24 15 INPUT MODE7 none - The Button Input */

0x034 0x37 /* P8_11 45 INPUT MODE7 pullup - Yellow Wire */

0x030 0x27 /* P8_12 44 INPUT MODE7 pulldown - Green Wire */

0x024 0x2f /* P8_13 23 INPUT MODE7 none - White Wire */

/* OUTPUT GPIO(mode7) 0x07 pulldown, 0x17 pullup, 0x?f no pullup/down */

/* INPUT GPIO(mode7) 0x27 pulldown, 0x37 pullup, 0x?f no pullup/down */

>;

};

};

};

fragment@1 {

target = <&ocp>;

target-path="/";

__overlay__ {

test_helper: helper {

compatible = "bone-pinmux-helper";

pinctrl-names = "default";

pinctrl-0 = <&pinctrl_test>;

status = "okay";

};

};

};

};

root@beaglebone:~/boneDeviceTree/overlay# more build

#!/bin/bash

echo "Compiling the overlay from .dts to .dtbo"

dtc -O dtb -o DM-GPIO-Test-00A0.dtbo -b 0 -@ DM-GPIO-Test.dts

Wrong dtc..

Follow:

https://github.com/beagleboard/bb.org-overlays

and run:

./dtc-overlay.sh

then use:

/usr/local/bin/dtc

root@beaglebone:~/boneDeviceTree/overlay# ./build

Compiling the overlay from .dts to .dtbo

root@beaglebone:~/boneDeviceTree/overlay# ls -al

total 20

drwxrwxr-x 2 root root 4096 Nov 12 2015 .

drwxrwxr-x 10 root root 4096 Nov 12 2015 ..

-rw-r--r-- 1 root root 986 Nov 12 21:23 DM-GPIO-Test-00A0.dtbo

-rw-r--r-- 1 root root 1591 Nov 12 2015 DM-GPIO-Test.dts

-rwxr-xr-x 1 root root 124 Nov 12 2015 build

root@beaglebone:~/boneDeviceTree/overlay# cp DM-GPIO-Test-00A0.dtbo
/lib/firmware/

root@beaglebone:/lib/firmware# cat $SLOTS

0: PF---- -1

1: PF---- -1

2: PF---- -1

3: PF---- -1

4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln

root@beaglebone:/lib/firmware# echo DM-GPIO-Test > $SLOTS

dmesg | grep bone

will show you more..

root@beaglebone:/lib/firmware# cat $SLOTS

0: PF---- -1

1: PF---- -1

2: PF---- -1

3: PF---- -1

4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln

cape-universaln is already loaded to..

disable by removing: "cape_universal=enable" from:

/boot/uEnv.txt

Robert you Rock !! Thanks man the problem has been solved at this end. Much appreciated.