gst-dsp setup / dsp-load check with gst-launch...

Hi there,

I’m following the instructions in in order to set up gst-dsp in BB-xM. But, I have faced with the following issue which worries me a lot.

Work Environment:
Kernel: 3.7.10-x13 → git://
Ubuntu: 12.10 (with minimal lxde desktop) →

root@arm:~# ls /lib/dsp
TSPA_Object_Code_Software_License_Agreement.txt mp4vdec_sn.dll64P
baseimage.dof mpeg4aacdec_sn.dll64P
conversions.dll64P qosdyn_3430.dll64P
dctn_dyn.dll64P ringio.dll64P
h264vdec_sn.dll64P test.dll64P
jpegdec_sn.dll64P usn.dll64P
jpegenc_sn.dll64P vpp_sn.dll64P

root@arm:~# ls /dev/ | grep DspBridge

root@arm:~# dsp-test
copied 1000 times successfully

(during dsp-test)

root@arm:~# dsp-load
load: 0, freq: 0
load: 0, freq: 0
load: 2, freq: 0

load: 64, freq: 0

load: 0, freq: 0

However, the DSP load stays 0 (zero) when I play the video by using gst-launch as follows:

root@arm:~# sudo gst-launch playbin2 uri=file:///media/root/USB20FD/BigBuckBunny_480p_surround-fix.avi

Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Missing element: AC-3 (ATSC A/52) decoder
WARNING: from element /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder available for type ‘audio/x-ac3, framed=(boolean)true, rate=(int)48000, channels=(int)6, alignment=(string)frame’.
Additional debug info:
gsturidecodebin.c(874): unknown_type_cb (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstSystemClock

Does this mean the system is not using DSP to play the video?

Also, I tried the following command but the DSP load didn’t change.

root@arm:~# gst-launch -v filesrc location=/media/root/USB20FD/BigBuckBunny_480p_surround-fix.avi ! dspvdec ! dsph264enc ! fakesink
Setting pipeline to PAUSED …
Pipeline is PREROLLING …
ERROR: from element /GstPipeline:pipeline0/GstDspVDec:dspvdec0: couldn’t start node
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …
Freeing pipeline …

Am I missing something during the setup steps described in

Looking forward to your comments/advice.
Thanks in advance.


At this time, i really should just drop that section of the wiki.. At
the time of it's initial writing, everything worked (2.6.37 days) but
back then Nokia had a full time developer working on the dsp for
Maemo/etc.. Who's infrastructure i utilized gst-dsp..

Fast forward to today, Nokia is essential no more and I haven't seen
anyone pick up this dsp stuff for maintenance.

So, essentially that dsp section on the page is a more of a memorial
at this point..

Patches welcome if you get it to work.. :wink:


Hi again,

After that e-mail I tried other cases such as running a pipeline to encode and send audio/video from BB-xM to Ubuntu-PC by using gst-launch, and I have realized that the “dsp-load” value is changing depends on the encoding type. I reckon this means the system uses the DSP for encoding if the type is matched with installed encoders in base image and dll files.

In short, it seems the gst-dsp is correctly installed into my BB-xM when I follow the instructions written in


Hint: If you are seeking dspbridge_dsp package for doffbuild, here is the link where you can get it.

The package is placed in dspbridge_omapzoom_v1.X.tar.gz.