Having trouble connecting BBBW to wifi network

Hello everyone. I’m very new to this sort of thing, so please forgive me if my question is stupid, but I’ve been searching and haven’t been able to figure out the solution yet. I posted this question in the “other” bbbw forum, but got no answers after several days, so I’m trying again here.

I have just updated my BeagleBone Black Wireless to the latest Debian image from the Beagleboard website. Now I’m trying to connect the BeagleBone to my wireless network. After a lot of time searching online I found several guides that all basically say the same thing: use connmanctl to connect, and… that’s it. Well, it isn’t working for me. Here’s what I tried right after flashing the BeagleBone with the latest image:

  1. I connected it to my Ubuntu laptop via USB
  2. I ssh-ed onto the BeagleBone as Debian: ssh debian@
    (using the default temporary password; I tried using “ssh root@” with the same password but I get the error message “Permission denied, please try again”).
  3. sudo connmanctl
  4. enable wifi > “already enabled”
  5. scan wifi > “Scan completed for wifi”
  6. services (displayed my local wifi network)
  7. agent on > “Agent registered”
  8. connect [wifi_blahblahblah] > “Passphrase?”
    I entered the wifi key > “Connected wifi_blahblahblah”
  9. quit
  10. ping www.google.com > “ping: www.google.com: Temporary failure in name resolution”

According to several guides I’ve checked out, it should now be working. I’ve tried giving it a few minutes and pinging again, but still nothing. Meanwhile, on my Ubuntu laptop, when I check available wifi networks I see “BeagleBone-D8EF”. Could it be that I can’t get the connection working properly because it’s set up to allow my computer to connect to it via wifi instead?

Does anyone know what I’m doing wrong? I would appreciate any help with the problem.

On Thu, 7 Sep 2017 21:27:55 -0700 (PDT),
puma_ad@hotmail.com declaimed the following:

1. I connected it to my Ubuntu laptop via USB

  Which is emulating a network connection

10. ping www.google.com > "ping: www.google.com: Temporary failure in name

  Does ping have the option of specifying to connection to use? I suspect
the BBBx may have the USB connection set up in the routing tables, and the
USB connection (on the host computer) is not set up to share the hardwired
network, so there is no name server available to it.

  If you pull the USB (hope you are using a separate power supply), can
the host computer ping the BBBx via a WiFi router?

  I don't have a WiFi Beagle (do have an R-Pi 3 -- and updating its OS is
a pain, since I have to use a TV/mouse/keyboard to navigate the GUI
startup, but that TV is no where near my hardwire switch -- but I can't get
configure the WiFi until much later in the process [especially as I
normally am configured for no SSID broadcast AND MAC filtering].

  I do know that, on my desktop machine, if I enable the WiFi to tether
to my phone (it's hard to run a video when the DSL is fighting to get to
1Mbps), I'm unable to print -- as the printers are on the hardwire switch
and Windows tries to route via the WiFi.