Having Troubles Getting Started - Keyboard Config & Radios

Hi,
I have just purchased a Seeed Beaglebone Green Wireless and am having difficulties getting it up. I see the following problems -

Remaining Problems

  1. RDP Keyboard layout is wrong
  2. Add a new admin user (‘Justin’)
  3. Enable WiFi
  4. Enable Bluetooth
    I have spent much more time than expected at this, see attached for detailed description of procedure. I have found instructions for each (#1-#4), but have failed to get these completed.

To start small, if possible, how can I correct #1? PuTTy works just fine (Serial & SSH).

Sitara Getting Started Notes.txt (2.38 KB)

WiFi/Bluetooth should work out of the box, running this should give us
some hints:

journalctl | grep wl18

Regards,

Hi Justin,

I think the RDP issue with the keyboard layout you are having is a tightVNC issue. Does the information in the following link describe what you are experiencing? Do you absolutely need a graphical session to the beaglebone?
https://unix.stackexchange.com/questions/346107/keyboard-mapping-wrong-only-in-specific-applications-under-tightvnc
https://www.reddit.com/r/BeagleBone/comments/a9122q/incorrect_keyboard_mapping_with_tightvnc/
https://groups.google.com/forum/#!topic/beagleboard/YCiECD0fiII

Regarding wifi and bluetooth, you would need to manually set up the networks using “connmanctl” which is already installed, or uninstall “connmanctl” and opt for using the network-manager package which has a nice cursors interface GUI for setting up ethernet or wifi networks. If you install network-manager, run “nmtui” for the network manager text user interface which is very nice.
https://www.digikey.com/en/maker/blogs/2017/how-to-setup-wifi-on-the-beaglebone-black-wireless
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/networking_guide/sec-configuring_ip_networking_with_nmtui

For creating users, all Linux distributions will be very similar and you can find lots of tutorials online such as this one:
https://linuxize.com/post/how-to-add-and-delete-users-on-debian-9/

Hi Robert & debounce,
Thank you for your help and shared content, greatly appreciated!

Here is my summary response to the points listed:
• journalctl: see ‘journalctl_report.txt’ attached
• user creation: working now, thank you
• wifi/bt: waiting for keyboard correction to proceed
• keyboard mapping: works: Chromium
wrong: QTerminal, File Manager
*e.g “abc123” → “asd90-”

Still not sure what the issue with the keyboard mapping is, I have tried so many options. I tried TurboVNC as requested, the same problems occurred.

Thank you for the help! Let me know your thoughts on the remaining opens

journalctl_report.txt (2.47 KB)

Hi Justin,

Is your keyboard a US english standard keyboard? Did you verify that the operating system keyboard is also set to US english in the Debian system settings?
https://wiki.debian.org/Keyboard

If your operating system keyboard settings are correct, it is still a VNC or Xkeybord issue, can you try setting the Xkeyboard default keyboard to US keyboard via terminal command line "setxkbmap us", where "us" would be US for US keyboard :
https://unix.stackexchange.com/questions/458680/cant-change-keyboard-layout-inside-vncserver

Per the manual page, if the configuration is not the same on the client and the server, you can have keyboard mapping issues. I suggest reading the note at the bottom of the manual regarding xkbcomp on the client side:

setxkbmap us -print | xkbcomp - $DISPLAY

Read more at: https://www.commandlinux.com/man-page/man1/setxkbmap.1.html

setxkbmap us -print | xkbcomp - $DISPLAY

Read more at: https://www.commandlinux.com/man-page/man1/setxkbmap.1.html

https://www.commandlinux.com/man-page/man1/setxkbmap.1.html

I don’t use VNC, but I think that should point you in the right direction. Please let me know if that helps

On Sat, 3 Aug 2019 09:11:48 -0700 (PDT), debounce
<morales.jacobj@gmail.com> declaimed the
following:

Hi Justin,

Is your keyboard a US english standard keyboard? Did you verify that the
operating system keyboard is also set to US english in the Debian system
settings?
https://wiki.debian.org/Keyboard

  I did a Google search for keyboard layouts/mappings and couldn't find
any that mangled the numerics that much. All of them tended to keep 1-9,0
in that order. Didn't see any that had that mangling of b->s and c->d
either. Might be helpful if the OP, rather than showing what "abc123" came
out as, showed what the "asdfghjkl" and "qwertyiop" rows generate.

  Most variants were "qwertz" or Dvorak, and the latter puts "s" on the
right hand...

Hi Guys,
Thank you for the detailed help, this is very appreciated. My keyboard is stand QWERTY, the observed key behavior is below:

Keyboard Responses:

  • asdfghjkl → abfhjk;’`
  • qwertyiop → c.gvnlzx
    setxkbmap was not available for use. Thank you very much for the /etc/default/keyboard listing, I think this is the simple key!

For /etc/default/keyboard, which settings to use? I looked into /usr/share/X11/xkb/rules/base.lst and there are many options, which for QWERTY with my Logitech MK710 unit?

Thanks for the help! :slight_smile:

On Sun, 4 Aug 2019 19:26:48 -0700 (PDT), Justin Reina
<justinmreina@gmail.com> declaimed the
following:

Hi Guys,
Thank you for the detailed help, this is very appreciated. My keyboard is
stand QWERTY, the observed key behavior is below:

*Keyboard Responses:*

  - asdfghjkl -> abfhjk;'`
  - qwertyiop -> c.gvnlzx

  Again, nothing I see online shows such a combination... Ignoring
Dvorak, practically everything is either QWERTY, QWERTZ, or AZERTY.

  Ignoring the "b", abfhjk;' looks like a keyboard that dropped d/g/l
(and swapped b for s). No layout I've seen puts c.g on the top row.

setxkbmap was not available for use. Thank you very much for the
/etc/default/keyboard listing, I think this is the simple key!

For /etc/default/keyboard, which settings to use? I looked into
/usr/share/X11/xkb/rules/base.lst and there are many options, which for
QWERTY with my Logitech MK710 unit?

  I'd probably start with generic (pc101, 102, 104, or 105) keyboard
type. Then try logitech_base, logicd.

  With us or gb layout as applicable.

  As I recall, you claimed a web browser was picking up the correct
characters -- which to me implies the scan-codes being sent are correct for
the key, and it is the mapping from scan-code to letter which is failing.

A follow-up...

  I dragged out my HDMI cable and connected to my monitor, moved the
Logitech Unifying Receiver from my laptop to the BBB, and booted the BBB
using the image at
http://debian.beagleboard.org/images/bone-debian-9.5-lxqt-armhf-2018-10-07-4gb.img.xz
(since my normal BBB access is via PuTTY, I've flashed them with the IoT
image to gain more storage space*)

MK700/MK710 keyboard, M705 mouse.

  NO CUSTOMIZATION DONE TO THE BBB OS

  LXQT preferences for keyboard came up as English US, and Generic 105
key (International) PC keyboard. I did not attempt any cryptic X command
line utilities or remapping of keys.

  Opened Gvim, and typed the top two (alpha) rows of the keyboard.

qwertyuiop
asdfghjkl

  I'd strongly suggest writing the linked image to a fresh SD card and
booting from it. Since the receiver uses the same band as WiFi and
BlueTooth, I'd also suggest making sure the box and keyboards are not close
to other sources of RF.

* The normal 20" TV available for use is in my bedroom -- where there is no
CAT-5 Ethernet. My R-Pi's are 3B models with WiFi capability -- configuring
THEM from the bedroom is feasible. Normally I use a Logitech K340 &
Anywhere MX combo for that; the larger MK710 stays with the laptop on my
amateur radio desk.

Hmmm, I tried all steps you have listed, but the same result occured. Is this some sort of tightvnc-Linux bug, I have found some compliants of similar.

If so, how could I install a different server, e.g. ‘x11vnc’? I have the WiFi antenna connected but can’t figure out how to connect.

Thank you Dennis!! :slight_smile:

On Wed, 7 Aug 2019 18:15:37 -0700 (PDT), Justin Reina
<justinmreina@gmail.com> declaimed the
following:

Hmmm, I tried all steps you have listed, but the same result occured. Is
this some sort of tightvnc-Linux bug, I have found some compliants of
similar.

If so, how could I install a different server, e.g. 'x11vnc'? I have the
WiFi antenna connected but can't figure out how to connect.

  I have no experience with any VNC scheme, and very little with the
limited capability of Windows Remote Desktop.

  Some thirty years ago I did have some exposure to X11 but those were
using dedicated X-server terminals (yes, the client/server definitions are
strange -- in X11 the display terminal is the server, and applications
opening windows on the display are the client). When we had to use regular
systems we had commercial X-server software (Hummingbird -- now OpenText --
Exceed) running on Windows NT (or were running on desktop microVAX boxes
which came with X11 natively).

  The trick with these is that one typically does not export a full
desktop from a remote system, but only application windows (eg: use a PuTTY
session to the remote, enter the command to define X11 DISPLAY to be your
local machine, then start some graphical application which then opens on
the local display). [Windows specific]
https://sourceforge.net/projects/vcxsrv/
https://sourceforge.net/projects/xming/ (though the third image there does
look to be making a desktop login as the remote via XDMCP
https://en.wikipedia.org/wiki/X_display_manager )

I have been using mobaxterm for this kind of application. It encapsulates putty and an x server, and its free license has reasonable terms. It just works, without configuration. I believe it can handle an XDMCP session as well but I’ve never tried it.

Best

Jim

Hello,

Did you ever get the layouts of your keyboard to function?

Seth

P.S. Show me your layout if possible. Oh and you will need a self-powered USB hub for the keyboard and mouse. If you are still having trouble w/ the USB hub for your peripherals, try sudo apt install xfce4. That usually tends to be sort-of-lightweight and works for projecting X windows. Let me know what you think.

Hello,

dpkg-reconfigure keyboard-configuration <<< Try this idea.

Seth

P.S. I was just reading the Debian Manual. It seems if things are not already configured, which may be the case at any point in time thus far with anything, dpkg-reconfigure has an idea for it. man pages!