HDMI Port is dead

Hey Guys

Multiple issues with beaglebone right now.

There is some odd problem with HDMI on my beaglebone.

It is odd because

  1. It did not work out of the box
  2. It worked when I flashed an Image from the 5th of Sep, 2013
  3. Couple of days later, the same image did not work.
  4. I do not get any EDID information from terminal through ssh into the device
  5. xrandr --verbose returns “Can’t open display”
  6. Boot flags also do not function
  7. The display does not even detect that I have a HDMI device connected.
  8. I tried echo 0 > /sys/class/graphics/fb0/blank, but still does not fix the issue.

Now what’s the problem. Can it be a porblem with the port?
I mean, why would the same image work and then not work.

Also, the display I am using is from AOC.

I am new to embedded, but is this normal? Everything seems to be broken out of the box with the BBB

Not trying to be a pessimist, but should I just return the board?

Sushant Khanna

Did you go to the support Wiki and look under HDMI issues? If not, then I suggest you try that. The link is on the little white card that came in the box with the board.

You may also find other useful information on the main page, like maybe restoring the image. Sometime with Linux if you pull the power without shutting it down, the eMMC or SD can get corrupted.


HI Gerald

I did try the support wiki for HDMI.
I understand if it is an software problem, but it seems to be more of a hardware issue.
Even after re-flashing the same image i could not get any output.
My linux machine has an issue with graphic drivers so it does not display anything on the screen either, but when I plug it in the screen wakes up beacause it detects it.
In the beaglebone’s case, nothing is detected either. Also no xrandr --verbose output. Some blogs suggested me to get some info from there.

I am trying an Android image now. Let me see if that works.

Last comment not posted yet, I will anyway continue from there.

So I booted an Android image and it worked. I got an output.
The default video flag in uEnv.txt was 720x480-16@60
Except changing the 16 to 32, nothing else worked.
I finally removed the flag and got a 1280x 678+ res. This seems to be the highest common res between the two.

Now I have two follow up questions.

  1. What is the reason for the res limitation? Is it software or hardware?
  2. Can a similar problem be happening on Angstorm side as well? There were no flags provided when it had worked before, should it not work fine still?

Waiting for a reply.


As you know, the HW does 1920 x 1080 on monitors that support it.


1920x1080 is listed at 24hz.
My monitor and my TV both support full HD with all other devices. However they are normally at 60hz or similar.
Is this an HW limitation?

Quick update,
I checked on my TV with Android image and it has a full 1080 output at 24p(Or hz or fps, I am guessing I can use them interchangeably in the context)
My monitor on the other hand cannot support 24p/hz. I tried to force it through my laptop and the screen kept flickering.

Thanks Gerald for all your help.

Can you or anyone else offer me any guidance as to why certain displays support 24 and why does the BBB only support 24 at this res?
I’ll try to fix this if it is a software problem.


That is a HW limitation. 24Hz is the best it can do at 1920x1080,. No there is no HW mod that will change that. If it were a SW issue, we would have fixed it a long time ago.

However, if it is a real HDMI monitor, 24hz should work fine.


Thanks a lot Gerald.
Sorry that you had to still approve my posts. I registered but I guess it took sometime.

I will mark this as complete.

You are now approved. When you register, all posts are moderated until the first post is approved.



I had exactly the same problems with HDMI,
sometimes it worked, but most of the time there was no signal.

Then I changed the HDMI cable. Same size, but a better (more expensive) quality.
With the new cable it works now perfectly.


Sushant Khanna? Let's see who this is