HDMI Video out cannot display 800x600

Hi All. First time on here.

Been doing some work with the Beaglebone XM and for the most part got my project working on it, but wanted a quicker processor and smaller board so moved to the BeagleBone Black thinking it should be a seemless transition. It hasn’t turned out that way at all unfortunately.

I’m trying to have the BBB device boot at 800x600. I’ve added ‘optargs=video=HDMI-A-1:800x600@60’ to the uEnv.txt file and rebooted. The device boots but fails to show anything. I tried different cables and I also tried it on my TV. All of which worked on the BBXM, but not on the BBB.

I’ve SSH’d onto the device and typed ‘cat /proc/cmdline’ and can see that the video did indeed set to 800x600. I changed the line to ‘optargs=video=HDMI-A-1:1280x720@60’, rebooted; and it worked. I then typed ‘cat /proc/cmdline’ and I can see it passed the video as 1280x720

I changed the res to 720x576@50 and it works still.

I really need the res at 800x600. My TV and Monitor supports that resolution so how come all of a sudden they wont display this resolution? Remembering that I’m using the same monitors and cables that worked for the BBXM.

Thanks all - really appreciate any help you guys might be able to provide.

I'm not sure 800x600 is one of the standard resolutions available in the
kernel. Try adding an 'M' to have the kernel calculate the timings for
a custom resolution, ie: "800x600M@60" instead of "800x600@60". I ran
into a similar issue trying to drive my 800x480 LCD panel, details and
links to additional documentation are on my blog:


Also, you don't mention what OS you're running, but setting resolutions
at the kernel command line only works for the Linux splash screen and
console terminals, and for "Aftermarket" Debian (and probably Ubuntu...I
haven't tested) images, but *NOT* for the default Angstrom OS. The
Angstrom display setup for the BeagleBone Black overrides anything
passed on the kernel command line, and as of yet no one has successfully
determined a way to force the Angstrom GUI into a custom resolution.

If you can see the BeagleBone splash image while the kernel boots and
then a blank screen once Angstrom takes over, nothing(*1) on the kernel
command line will help you.

*1) I suspect passing a custom EDID to the kernel would fix this, but
you would have to recompile your kernel and enable
CONFIG_DRM_LOAD_EDID_FIRMWARE which is disabled in the default
BeagleBone Black kernels.