HELP: Beagleboard does not boot


my board doesn't boot after I have tried several images,
which have been working. Maybe it does not boot, because
I did some tests on the I2C bus.

All of my images do not boot any more, all with the
same errors:

Texas Instruments X-Loader 1.0 (Sep 23 2011 - 14:12:54)

Beagle xM
Reading boot sector
ading u-boot.bin from mmc

U-Boot 2011.09-00921-g5721385 (Nov 15 2011 - 18:17:10)

OMAP36XX/37XX-GP ES1.2, CPU-OPP2, L3-165MHz, Max CPU Clock 1 Ghz
OMAP3 Beagle board + LPDDR/NAND
I2C: ready
DRAM: 512 MiB
*** Warning - readenv() failed, using default environment

: serial
Out: serial
Err: serial
Beagle xM Rev C
No EEPROM on expansion board
Die ID #2bbc00229ff80000016830c40303401e
Net: Net Initialization Skipped
No ethernet found.
Hit any key to stop autoboot: 0
Unknown command '' - try 'help'

Lots of these INTERRUPT messages ...

Is there something, I can do to fix that?

The board is booting, but something has gotten messed up causing interrupts. You could try going back to the original card that shipped with the board and trying that. If that does not work, it may be that you have damaged your board. Is thee anything plugged into the expansion headers or were they used at all? Maybe exposed to voltage levels over 1.8V?


The Problem is independend of the used card.
When the problem occured, several things were connected:
- zippy2
- network
- serial port
- mouse and keyboard
The same configuration worked for several days without any change.

Now I diconnected anything, only the serial port is connected.
The interrupt problem is the same as before.
So it seems to be a hardware problem?

Most likely. It could be either the BeagleBoard or the Zippy. I suggest you remove everything from the BeagleBoard except the serial port and power and see if the board boots.


Yep, that's exactly what I already did.
Zippy2 is already removed.
Thanks Gerald.

Sounds like you may have damaged a pin processor. Best thing to do is to request a RMA and send it in to see if it can be fixed. If it is the processor, the memory will have to be replaced as well, so there may be a charge involved.


Hi Gerald,

is there any chance to get it fixed in Germany?
Shipping to and from TX might be quite expensive and time-consuming.

Is it possible, that I2C programming damages the hardware?
I did something like that:

Sorry, but no. If you bought it from say Watterrot they can swap it out for you under an RMA.


Hi Gerald,
is it possible, that I2C programming damages the hardware?
I did something like that:

I just don't want to destroy another board ...

There should be nothing you can to from a SW perspective to damage the HW. Without knowing exactly where the damage is, it is hard to say where the issue is. I have seen a couple of other instances where damage occurred when using Zippy boards, but I do not have enough information to understand the failure scenario and what may have been the cause. With so few instances, it is hard to get enough data.

If you send the board in we can look at the bad pin and then look at theh Zippy2 to see where the isuue may be.