Help!!! - lost connection to BB Rev C

I’ve been trying to connect to the internet via and USB with my BB Black Rev C and in doing so I Iost all USB connection to the BB !!!

As background my laptop is a Win 10 (64 bit system). I was able to connect to the Beaglebone and ping and from my BB using SSH or from my PC command window. I enabled sharing and used /sbin/route add default gw to be able to ping

Next I worked on the DNS resolution. This got me into problems. I modified etc/networks/interfaces to add nameserver and nameserver to the entry for usb0. The gateway was set properly and I changed the mask to I also added the nameserver lines to resolv.conf. Immediately after this, with out powering down pinging worked as did other websites… !!! success.

As a next test I powered down the BB and restarted. ------- Now my laptop does not see the BB. My ethernet 2 adapter, which was the BB gateway, says media disconnected. Using a web browser on or times out with an error, no website found…

How do I recover, AND, what could have caused this problem.

------ Thanks for your help, awaiting all replies.