Help using Chipsee screen


I’m having trouble getting my Chipsee Display to work with my Beaglebone black. I’ve tried the following

  1. I tried to make it run with the Angstrom and Debian images they provided.
    The screen worked and so on, but I couldn’t get my UWN100 WiFi Adapter to work; despite the driver being installed on the image they provided. For the project I’m doing it is kinda needed. I’ve tried to make it work for about 5 days, and thought it was time to try something else; so I…

  2. Tried to use the latest Debian image (2014-05-14). The WiFi was working at last! But unfortunately the display wasn’t. So I tried several fixes suggested in this forum, like copying the boot folder from the Debian/ Angstrom versions Chipsee provided. I got to the splash screen and the pinguin, but afterwards I get a black screen with a flashing underscore (when my keyboard is plugged in I can type, but it doesn’t respond to commands). After wrestling with this for another couple of days I thought to try something else.

  3. Finally I tried to install Jessie (Debian version; still in testing fase). But when I try to flash Jessie the leds light up in the following pattern USR0 → USR1 → USR2 → USR3 → USR0 and so on. I left it on for about an hour and still saw no difference. Do I have to wait longer, or is it maybe my fault for using windows to create the bootable SD-card and it should work with Linux?

In the most ideal situation I’d like to work with Weezy and get the display to work on it. But I have no idea how to do this. Is there someone who can point me in the right direction?