How to avoid vi and nano editors resetting Putty number of lines?


I am most of the time accessing the Beaglebone through the serial console using Putty. Every time I open a vi or nano editor, the number of lines that is actually used is set to 25, even if the window is much larger. Worse than that, after leaving the editors, that size stays permanent and requires a “Reset Terminal”. I’ve also tested several of the disabling functions but none of them helped.

While working over a ssh console, it is not a problem, even with Putty.

Anyone who knows how to get rid of this problem. Not answer “use Teraterm” or others please, the question is only for Putty.

Thanks, Günter

Does your Putty setting (Terminal -> Keyboard) match what's listed in
the getty line for your serial port (typically in /etc/inittab, and
vt102 in RCN's Debian images)?

Hello Charles,

yes, this helped. I did not know that the two values must fit to each other. Good to know.

Thanks a lot, Günter