How to change color bit depth

I followed the advice generously offered by others here, expanded the file system to the full 64G on my uSD card, burned a fresh Debian Jessie image from, and am now running nicely from the card. So I reinstalled JRiver Media Center 21 (which I love and have running on multiple other machines - including a Pi 3 - and had running on my 'bone during their development & beta period for Linux on ARM), expecting everything to be fine - but the JRMC window is just a white rectangle. The advice I got from the JRiver tech staff was that the color bit depth on my BBB is probably set to 16 (which turned out to be correct) and has to be set to 24 for JRMC to display properly. So I edited /etc/X11/xorg.conf to change the bit depth from 16 to 24 in the display section, and I couldn’t reboot afterward. I got everything back to the above state again but changing the display section in the xorg.conf file from 16 to 24 again prevented booting and I had to restore the original intact image to get it running. And I cannot find any other configuration file with a color bit depth setting in it.

This has happened to others - there are several posts on various boards about it. But no one has posted a solution anywhere else. Does any of you have an idea how I can get my display up to 24 bits? Thanks!!


This is a hardware limitation of the beaglebone black in it's default
state... The HDMI framer chip used is only wired to the am335x in 16bit


So the reason I could use JRMC before was that I ran headless and configured it via TightVNC - I never had a monitor connected to the 'bone. I’ll go back to that approach - thanks!!