How to connect Beaglebone blue to *any* network, except a simple Wifi

Firstly, via USB. I set a gateway on Beaglebone, but the desktop (host Ubuntu) does not care. There are some instructions on the internet, followed by “if does not work add use echo 1 > /proc/sys/net/ipv4/ip_forward, a thing with iptables, whatever”, it all did not work, ping on the bone does not work. Someone told that you need to put the respective interface to a “trusted zone”. I do not know where I can found that zone. To add a VPN connection. “Add a VPN connection” is grayed on my system.

I did not want to touch wifi, because I would prefer beaglebone to be a hotspot, but if it did not work with the cable…

Firstly, there is “connman”, to make it easier. I tried connman, but the wifi network is enterprise tunneled double-authentication etc, connman just prints “invalid arguments” when I try to connect. There is some wpa-supplicant-like configuration file, added it as instructed, but no effect, all I see is still “invalid arguments”. No detailed error, no problematic file, no problematic line, no list of these arguments, nothing, just “invalid arguments”.

Lastly, there is wpa-supplicant itself. I made a respective file, but it all starts and stops with

$ wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0
Successfully initialized wpa_supplicant
Could not read interface p2p-dev-wlan0 flags: No such device
nl80211: Could not set interface ‘p2p-dev-wlan0’ UP
nl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
p2p-dev-wlan0: Failed to initialize driver interface
P2P: Failed to enable P2P Device interface

There is nothing about p2p-dev-wlan0, whatever it is, in wpa_supplicant.conf

Could you please help me? I had never problems with RPi, with BBone Black, but Blue, no idea. I am not a network expert and I do not want to be one. I just want to apt update etc. Thanks.

For enterprise, you'll need a config file, see the "Eduroam" example:



Thanks Robert, I know. I have created that file. It is something like wpa-supplicant.conf, but different. Connman did not react to that file, or at least all that it prints is still “invalid arguments”, as in the case when the file did not exist.

Hi Tarmo, yes one of these pages with instructions also informed that network-over-usb it is a non-recommended struggle, which may not even survive a reboot.

Thanks for informing me that a USB-Ethernet dongle will work though, I did not know that.

I like these little things, USB - wifi for under $5. I have a few of the little ones like this, but more of the kind with gain antennas about 6 inches long. Mostly Realtek, one Ralink. Some Linux versions don’t have a decent driver for Realtek, but mostly just Armbian.

I’m not sure if I’ve ever plugged in 2 of them at once like if you wanted to make a hotspot that’s fed by another network,. I’ve been using Android phones as hotspots for several years, that’s my only internet connection. Look at the man page for iwconfig for nitty-gritty details. I have no experience with wpa, I run an open network (rural area).

This is old-school but I use an /etc/network/interfaces file that’s just

auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp
wireless-essid Moto_lte

For both Raspbian and Debian. Your first wireless interface becomes wlan0. You add a wired one like:

auto eth0
iface eth0 inet static

Into the same file. I like wifi better than I expected to. It’s not as fast as wired but it’s a lot more convenient. Unless you’re running an embassy and the Russians are snooping into what you do with directional antennas to steal secrets.