How to disable SoftAp0 with address 192.168.8.1 on BBGW?

I’m running BBGW-blank-debian-8.5-seeed-iot-armhf-2016-06-19-4gb.img on a BBGW. I’ve used connmanctl to configure the wifi network to which I want to connect, and everything is working OK so far. On bootup, my BBGW does DHCP an address and I can ssh into it.

What I’d like to do now is disable the SoftAp0 interface with the 192.168.8.1 address. What is the correct/clean way to do this?

If I run “sudo systemctl disable wificonfig.service”, then wifi doesn’t come up at all the next time I reboot.

SoftAp0 is created by the wifidog service:

wifidog-pre-startup.service
&
wifidog-gateway.service

https://github.com/rcn-ee/repos/blob/master/seeed-wificonfig-installer/suite/jessie/debian/wifidog_pre

Regards,

SoftAp0 is created by the wifidog service:

wifidog-pre-startup.service
&
wifidog-gateway.service

https://github.com/rcn-ee/repos/blob/master/seeed-wificonfig-installer/suite/jessie/debian/wifidog_pre

Thanks, Robert.

For anyone else running into this, here is the simplest solution I found to ensure wlan0 still comes up, SoftAp0 doesn’t, and the nodejs process isn’t started at bootup:

https://www.ccoderun.ca/programming/2016-06-29_BBGW/index.html#softap0

  • edit /usr/bin/wifidog_pre
  • at the top of the script, add this line: touch /tmp/wifi.up
  • at the bottom of the script, comment out systemctl start of wificonfig.service
  • at the bottom of the script, append these 2 additional lines:
    systemctl stop wificonfig.service || true
    systemctl disable wificonfig.service || true
  • save the file and reboot the device

And if like me you don’t have a cell phone or other bluetooth device to configure the wlan0 interface, I have that figured out and documented here: https://www.ccoderun.ca/programming/2016-06-29_BBGW/index.html#wifi

Stéphane

And if like me you don’t have a cell phone or other bluetooth device to configure the wlan0 interface, I have that figured out and documented here: https://www.ccoderun.ca/programming/2016-06-29_BBGW/index.html#wifi

I meant to say wifi, not bluetooth.

Stéphane