How to disable udhcpd on the latest (6/5/2014) debian flasher image?

I put the latest console image of debian on beagle bone, and notice that when I do a ps aux I see

/usr/sbin/udhcpd -S
/usr/sbin/udhcpd -S /etc/udhcpd.conf

I believe this is for a dhcp server, which I don’t need (I only use dhcp as a client on the beagle bone)

I attempted to disable it with:

update-rc.d udhcpd remove

and then rebooted, but they still show up.

Is there a way to disable these if they are dhcpd servers?

It's started here:


It's used to easily setup the usb-otg ethernet connection so you can
ssh in over usb.


Thank you very much. If I am reading the script correctly, I can disable this by deleting /etc/udhcpd.conf.
I did that and rebooted, and I don’t see the processes.

For whatever radon, it was causing problems with my routers dhcp server. Other devices on the subnet ( would get a correct ip, and then it would be replaced with an ip on the subnet. I didn’t see that with the May image.

It appears to be working now, so again, thank you for your help.