How to get the latest ubuntu image for Beaglebone Black (via MicroSD Card)?

Hi,

I’d like to install the latest version of Ubuntu on my Beaglebone Black, but all the pre-configured images of SD Card I found in this page(BeagleBoardUbuntu - eLinux.org) are out of date and it shows 404NotFoud. How can I the latest ubuntu image?

Hi @M1chelle ,

Sorry with all the development going on at BeagleBoard.org, any “non” Debian image wasn’t really a priority, thus it never got tested.

I triggered a rebuild of this config:

Feel free to build it yourself as:

./RootStock-NG.sh -c rcn-ee.net-console-ubuntu-focal-v5.10-ti-armhf

You should see a build show up here:

https://rcn-ee.net/rootfs/ubuntu-armhf/

As for as support, it is as-is… As i don’t test it…

Regards,

Freshly updated:

https://rcn-ee.net/rootfs/ubuntu-armhf/2022-02-07/

Regards,

Thank you so much! Actually I just want to run ROS on the Beaglebone Blcak. It seems that the latest version of debian also supports ROS?

Thanks,

1 Like

Hi @M1chelle for ROS… use the posted focal image with this install instructions:

http://wiki.ros.org/noetic/Installation/Ubuntu

Regards,

1 Like

Hi, all images again lead to 404 pages.

Renamed… Index of /rootfs

Thanks.
I have a BBB (bought last week at Farnell’s so a recent one) and I’d like to use Python3. Do you advise to upgrade to ubuntu or just stick with Debian and install python3? (soory for the dumb question, newbie here)

For python3… Well that has been the default for a number of years now… you’ll be fine…

So you mean, no need to flash ubuntu, just install Python3 on Debian?

It’s already installed…

Ah? When I launch python, I get version 2.7
Should I launch python3 ?

Debian has a package for that. Your image is old, it has python2 setup as python. If you want python3, run it as ‘python3’ in older images…

Regards,

Thank you. Then, if my image is old, which file do you suggest I should download from your folder ( Index of /rootfs) ? I’d like to flash the eMMC. Thanks again for your help…

Pick one of these:

https://forum.beagleboard.org/tags/c/general/8/latest-images

Regards,

Thanks @RobertCNelson
I believe this one should be ok:

Debian 11.x (Bullseye) Xfce Desktop Snapshot

If you want Bullseye, then you select this one:

Regards,

Hi
I have tried to flash the eMMC of my BB Black, with no luck so far. Maybe I did something wrong?
I followed the instructions from here:

  1. I downloaded the xz file from here, as you suggested in your previous answer
  2. Then I decompressed it and flashed the image on a 4GB SD card (tried from Windows and Linux)
  3. Then I pressed the Boot button and plugged the 5V supply (official 5V 2A)
  4. But I never got the fancy user leds flashing (only the usual heartbeat from led0)

I tried this twice, copying the image on the SD card from Linux (sudo dd if=./BBB*.img of=/dev/sdX) or Windows (with Win32 disk imager), but both times I didn’t succeed, although this stage seemed fine both times.

The BBB is still running Debian 10 Buster version.
What did I do wrong? Can you help me flash the board correctly?
Thanks for your help

Have you got a serial cable connected ? Generally when things don’t work as expected when booting, it really helps see what is going on.

Hi, thank you for your answer
I only have the supply. I insert the SD card, hold the Boot button and plug the supply in, then release the button after a few seconds.

Actually, I have never tried to have both the supply and the USB cable connected at the same time, in case of any conflict… Is it safe?