how to install cmemk kernel module on beaglebone ai

I’m trying to run the opencl examples. Where can I find the cmemk.ko module?

As far as I can tell, cmemk should be already running if you use one of these images:

Nevertheless, when I changed the kernel on my system, I had some issues getting cmemk running. For me running /opt/scripts/tools/ fixed this.


Thanks. I was trying this one: Debian 10.0 2019-07-07 4GB SD IoT

Ugrading the kernel with /opt/scripts/tools/ worked for me, but it still doesn’t include the driver.

Does this look right for the kernel version? Is there any other way to get the cmemk.ko driver?


debian@BeagleBoard-X15:~$ uname -r

cmem was added to the v4.19.x-ti kernel around: Sep 25, 2019 (after 2019-07-07)

So... From:


run "git pull"


That worked, but now I get a segmentation fault when I try to run the float_compute example:

debian@BeagleBoard-X15:/usr/share/ti/examples/opencl/float_compute$ sudo ./float_compute

This example computes y[i] = M[i] * x[i] + C on single precision floating point arrays of size 2097152

  • Computation on the ARM is parallelized across the A15s using OpenMP.
  • Computation on the DSP is performed by dispatching an OpenCL NDRange kernel across the compute units (C66x cores) in the compute device.

RunningSegmentation fault

Switch to v4.14.x-ti, now that i'm back from vacation, i'm jumping
back into my work on v4.19.x-ti + opencl..