How to make WiFi link faster?

I was able to get the device up on WiFi fairly seemlessly, but the link is sloooow. I’m using a recent stretch-iot release.

Anything I can do to optimize it? How do I disable SoftAP for example? I bet that will help quite a bit. I tried to use the connman disable tether command but SoftAP still shows up in ifconfig