How to recover -xM nand contents?

I have erased nand contents of my -xM. Can I follow the instructions
give for other revs (C4) by Nishant?


Th Beagle-xM doesn't have any NAND to be erased. There is no NAND on the
xM boards.


Basu - your xM may report that it has NAND, but that memory is inaccessible and unsupported.

Is it possible that you mean you accidentally erased the contents of your SD card? In that event, we can help. :slight_smile:

Thanks Dale and Jeff,

I am unable to boot, may be its the SD card then?
I was trying to load Angstrom and followed instructions which had
'nand erase' and 'nand write'.

If its SD card, how would I fix it? Any references on that?


That depends greatly on how you were trying to load Angstrom, and how it is failing. It sounds like you were following instructions based on older rev.C boards.

The first step is to download files that are known to work on your xM. You can find these on the Angstrom site here:

Download MLO, u-boot.bin, and the big file called


which contains the root filesystem.

On the card, verify that you still have two partitions, a small FAT partition and a larger one in ext2 format. Then:

  • Copy MLO and u-boot.bin to the FAT partition.
  • Un-tar the rootfs file to the ext2 partition.
  • Copy uImage from the root filesystem’s /boot directory to the FAT partition.

Then try rebooting. If that doesn’t work, let us know.

You can also find a lot of this information on - here is one page specifically on the xM:

hope this helps!


Do you have a -xM Rev A2? then search this mail group for a post that I made, probably first days of this month, it contains the steps to recover the nand state (if you did write something to it then it wont boot, no matter what the contents of the SD)

To avoid large discussions like the last time:

*Disclaimer, be warned that nand on -xM A2 is not supported and should not be used


Thanks Jeff,

I followed the instructions. When I reboot the board, I get strange
characters on my serial terminal and nothing happens after that.
Should I rename "uImage.2,xx.xx" to "uImage".
Anything else I am missing?

I tried renaming the file. Same result...

Yes, uImage should be named uImage - but it sounds like you aren’t getting that far.

On your card, make sure the first partition is FAT16 and then copy MLO and u-boot.bin from the site listed below. You should get through x-loader and u-boot to a boot countdown. Let us know when you get that far.

If x-loader comes up but u-boot fails or stalls, try booting with the USER button pressed. If that works, stop the countdown and do a

nand erase

Thanks Jeff,

I will try that. I realized one more thing. I had the first partition
as FAT32, may be that is one of the reasons?
Will try FAT16 and and see how far I will go.

Thanks again

I tried with FAT16 and same result. I do not get X-Loader.
When I boot from the sd card that came with the beagle board, I get
the x-loader and the countdown. I tried all the diagnostics given in

and I get all of them right expect for the video part.

When I use the my own sd card with angstrom in it, It does not
respond. Only strange characters on terminal.


So did you partition the 'sd card' your self and it doesn't work? Use
a script such as:

to set it up...


Yes, FAT16 is the way to go with all Beagles.

Which MLO and u-boot.bin did you copy to the new FAT16 partition?

Jeff Osier-Mixon wrote:

Yes, FAT16 is the way to go with all Beagles.

FAT32 works as well

I have used GParted to partition and format the MMC.

For a different try, I followed the steps from here

and got the login in command line but did not get the GUI. I tried to
install GUI following the instructions mentioned in the web page but
no luck. But at least I can get something working here.

I would still like to get Angstrom working.

Thanks again

by "no luck" what do you mean? Please list the specific
warning/error/issue/etc you saw...