How to recovery after disable eMMC in uEnv.txt

I uncorrectly disable eMMC in my Beaglebone Black Rev. C by following steps:

  1. Mount the FAT partition:

$ mount /dev/mmcblk0p1 /mnt/card

  1. Edit the uEnv.txt on the mounted partition:

$ nano /mnt/card/uEnv.txt

  1. Enable following line in uEnv.txt


Then I can not boot again, following message show on screen:

[ 0.741541] omap_hsmmc mmc.5: of_parse_phandle_with_args of ‘reset’ failed

then I boot into

Busybox v1.20.2 (Debian 1:1.20.0-7) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

/bin/sh: can’t access tty; job control turned off

Since there is no /dev/mmcblk0p1 now, I can not mount it and edit uEnv.txt again.

Then how can I recovery my eMMC from this point?

I got the same problem. Have you solved it?

Have you tried downloading an image from and writing it to an microSD card and booting from that? I recommend the etcher utility for writing the SD card. Any of the images should work.

Once you’ve booted the SD card you can mount the eMMC with:

sudo mkdir /mnt/emmc
sudo mount /dev/mmcblk1p1 /mnt/emmc

And edit the uEnv.txt file in the eMMC:

sudo nano /mnt/emmc/uEnv.txt

If you’ve correctly fixed the uEnv.txt file, shutdown, remove the SD card and you should be able to boot from the eMMC again.

Newer images create only a single partition, and use a “virtual MSDOS partition” and only a single partition. I prefer the new arrangement.