How to remove UU i.e. Busy state for i2c 2 line for Bullseye Debian Beaglebone Black?

I am working on Bullseye Debian image on Beaglebone Black and I was trying to connect my FRAM device on i2c2 line i.e. Pin 21 and 22. I am getting busy state i.e. UU in that for Addresses 0x54 to 0x57.

I also followed the steps mentioned in post Set up expansion EEPROM i2c-2 BeagleBoneBlack Rev-C. By Robert Nelson but it did not work for Bullseye debian image.

When i comment out the “enable_uboot_cape_universal=1” in uEnv.txt file, it does not turn ON after reboot.

Can anyone please help me in this?

0x54 → 0x57 are automatically loaded as at24 eeprom by the default device-tree… You’ll need to rebuild the device tree with those nodes disabled:

Which kernel are you currently booting? uname -r ?


Hello Robert,

Thank you for the reply!

The Kernel i am having is 5.10.168-ti-r72

So what should i do now to disable those nodes?
Thank you in advance!

Those nodes are right here: src/arm/am335x-bone-common.dtsi · v5.10.x-ti-unified · / BeagleBoard-DeviceTrees · GitLab

So i’d do:

git clone -b v5.10.x-ti-unified
cd ./BeagleBoard-DeviceTrees/
(edit src/arm/am335x-bone-common.dtsi)
sudo make install_arm


1 Like

By edit you mean remove all the section related to i2c2 0x54 to 0x57 from am335x-bone-common.dtsi file?


Hello Robert,

Thank you for the help!
It did work!

But now my RTC chip i.e. DS3231 attached to same i2c2 line is having issue of UU i.e. busy state.

I am able to see the two rtcs i.e. system clock and my external ds3231 rtc as i loaded the already present BB-I2C2-RTC-DS3231.dtbo in uEnv.txt i.e. added the below line in uEnv.txt file
because of this issue i am not able to read the external clock time.

Can you please help in that?

It’s UU as you told the system to take it with ^…


Hello Robert,

It did work!
Thank you for all the help:)

Thanks & Regards,
Kavan Mehta