How to ssh over USB work with Debian Wheezy 7.6

Hi everyone, I’m new on the forum and decided to register since I couldn’t find an answer to my problem.

I have a BBB (rev A6A) which shipped with Ångström, with this it worked perfectly to ssh over USB with ip

I decided to switch to Debian Wheezy, and I now have 7.6 with kernel “3.8.13-bone30” and simply connecting the beaglebone USB cable that came with it to my computer (windows 8) does not result in anything, it does not even show up as a device of some sort. I googled around and managed to come a little closer to a solution, but I am now stuck. Here is what I can do:

I work my way to /lib/modules/3.8.13-bone30/kernel/drivers/usb/gadget and there I can “modprobe g_ether”, which makes my windows computer recognize the beaglebone as a linux modem/router (something similar) and it shows up in device manager. I then follow the guide from here (section “Connect with your beagleboard using VNC and ethernet over USB”), I managed to “ifconfig usb0” and give it an ipadress and it even says that it is sending and receiving packages, but I cannot ssh into it using the ipaddress that “ifconfig usb0” mentions. It feels like I am missing something vital. What do I need to do to be able to ssh over USB with debian wheezy in the same fashion as I did when i used Ångström?

TLDR; ssh over usb worked with ångström, switched to Debian wheezy 7.6 and this no longer works (windows 8 does not recognize the BBB automatically and BBB does not want to load the correct usb-drivers). What to do in order to ssh over USB??

Thanks in advance!

Please be more specific, what version of "debian wheezy" (file name
used to flash)

Setting up the usb gadget driver to do that takes a script, so not
every image has it enabled.


My apologies. I used quite an old image debian-wheezy-7.2-armhf-3.8.13-bone30.img.xz from .
lsb-release -a gives “Debian GNU/Linux 7.6 (wheezy)” and
uname -a gives “Linux debian-armhf 3.8.13-bone30 #1 SMP Thu Nov 14 11:19:20 UTC 2013 armv7l GNU/Linux”


I was guessing that.. The "bone30" kernel is so broken..

Use a newer image from..

Which has the usb gadget connection enabled by default.


Thank you very much sir! Ill try the newer image and will return here with the results.


Thank you very much sir! Ill try the newer image and will return here with
the results.

Quick note, the "console" is meant to be small, so it doesn't include
the dhcp server needed to do the usb gadget network connection, so
it's not enabled in those two images..

the lxde/lxqt images have it enabled..


To add what Robert has said in his last post. It is fairly trivial to setup your network manually using g_ether / g_multi + cdc_ether etc. You just nee to use modprobe on the BBB, and host machines, and then bring the interfaces up after correctly setting up /etc/network/interfaces.

Now do note that if you do not know how to do the above do not ask on this forum . . . this is basic Linux / Debian knowledge with information strewn all over the web . . . if you’re still unsure what to do . . . start by googling “g_ether network setup” from which you’ll be greated by millions of hits . . .I say this for the lurkers out there more so than for the OP who seems to know a bit about Linux already.

Thank you Robert, it was indeed a bad kernel that was the problem. I’ll be more thorough with them in the future. And to William: thanks…