I can ping on Ubuntu but cant ping on Windows

I am using AM3358 BBB. Its configurated but I cant ping USB port on Windows. Its work on Ubuntu, any ideas? I want to check files inside the BBB is it enough if I do this on Ubuntu?

It is certainly fine to access the BBB with Ubuntu.

You should be able to use ssh to open a remote session in a terminal window.
Likewise scp will also work.

I am sure Files could also browse the BBB, but you may need to install an extension. I don’t use Gnome, much prefer KDE and Dolphin. Dolphin can browse remote systems out of the box.

If you need the BBB to be able to access the internet via your Ubuntu machine you will probably need to make some changes on the Ubuntu side to enable packet forwarding and set up some simple firewall rules to forward traffic from the BBB.

Not too sure what your issues are with Windows, but then I steer clear of that as much as possible. The BBB doesn’t do anything different if the USB host is Windows or Linux, so pretty sure the issue is with Windows as it works with Ubuntu.

Either Windows is not picking up the USB ethernet device, or it is getting assigned a different IP address or you have a firewall or virus software that is blocking the ip address.

Is it possible that the Windows one is

I seem to remember that the IP would be different depending upon whether it was on Windows, macOS/OS X, or Linux.

The situation is, I’ve got 3 BBB and 2 of them are configurated and not reachable on Windows, about the one that not configurated i can ping this on Windows. So I think it might be about confiuration. I tried to reset them to fabrication settings with sd card but couldn’t do it. Then i tried to reach them ubuntu and it worked. I think there is no problem with the these 2 BBB and they dont have connection problems?

Hi @Gulsum_Toker

If there is nothing you wish to keep on the boards I would suggest flashing them with the latest version. From your other post it looks as though they have pretty old images on them.

The latest version can be found here

You will need to download the correct version for your boards. For the BBB you will need one of the -armhf versions. There are 3 varieties minimal/iot/xfce each taking up more space than the previous version.

You can choose either Debian Buster or Bullseye versions. In the folders you will see many images. For the BBB you need one that includes am335x in the file name. If you want to flash the eMMC download one with eMMC-flasher in the title. This should automatically flash the eMMC when you boot from the sd-card. If it doesn’t have eMMC-flasher it should just boot from the sd-card and not do anything with the eMMC

Obviously if you wish to retrieve data from the BBB’s, download a non-flashing version and just boot from the sd-card. It should then be possible to mount the eMMC filesystem and edit/retrieve data if you wish.

I would also highly recommend getting a serial console cable. These are invaluable when having issues with the boards.

Assuming you can actually log into the boards from Ubuntu I would say they are fine, but that depends on what you want to do with them.

Do you know the history of the boards ?
Have they been used before for something ?

Yes i know that they used before as datalogger

If you don’t mind wiping them I would suggest re-flashing.

Otherwise you should be able to boot a new version from the sd-card.

Can you get a serial console cable ?
If the boards have been used before, unless you know the username/password that won’t get you very far.

How can I re-flash?

Ok you will need to download one of these files.




I would try the minimal version first as it should be quicker to flash and give you more free space on the eMMC. But it depends what you plan on using the boards for.

Extract whichever file you download and write it to an sd-card. It will need to be at least 4Gb in size.

The with power removed from the BBB insert the sd-card. If I remember correctly hold down the small button just above the sd-card slot and then apply power. Give it a couple of seconds then it should be fine to let go of the button. That should boot from the sd-card and start flashing the eMMC.

The leds should be flashing while this is going on. I think at the end they all stay lit, or perhaps all off. I really can’t remember. It will take a few minutes so grab a cup of coffee. Once done, remove the power and remove the sd-card and that should be it, assuming there were no issues.

This is where the serial console cable is useful to see what if happening.