I can't make BBB rev A5C & LCD7 Cape rev 3 work together :-(

i’m the newest newbie of all, and I’m having a problem that I can’t fix. I will try to be as specific as I can:

I have to confess that I don’t know a word of linux, apart from ls, cd and these kind of commands…

I’ve bought 4 BBB’s recently, that are marked as Rev A5C, and 4 LCD7 capes, being rev A3. reading the documentation of the LCD cape, it says that i need to update the software of the board. After many tries and falls, i’v managed to change the firmware in the eMMc to “Cloud9 GNOME Image 2013.09.04”, available on http://beagleboard.org/latest-images. The board is working properly, as far as I can say: it boots, and I can access thru ssh and see the contents of the flash or execute the Cloud9 environment.

But I haven’t been able to connect successfully the lcd cape. Somentimes, it seems to boot, and even shows the calibration screen, but then it freezes, most of the times with a blinking cursor on the top of the screen.
Another awkward behavior is that sometimes (can’t remember with which software version was) it had booted properly and showed the Desktop, and i have run applications in graphic mode.

Attending to http://www.elinux.org/BeagleBone_Black_Capes , there shouldn’t be compatibility issues between these two boards, so I’m totally depressed.

Reading the posts on this group, all of you seem to be experts on compiling, installing and doing awesome things with BBB’s.

So I’m begging any help. No one have had this problem? Could anyone show me some light? I might remember that i have a deep unknowing of linux, kernels, makes and so on. Also, I don’t have the ftdi serial cable (although i could build one).

Thanks in advance,
Manuel P.


It sounds like your LCD7 Cape may have issue with the signal integrity when booting with BBB: http://elinux.org/CircuitCo:BeagleBone_LCD7#Known_Issues

Have you tried booting up your LCD7 + BBB setup from a bootable SD card? The process of creating this type of SD is similar; however, instead of flashing the eMMC on BBB, it will allow you to boot directly from the BBB’s micro SD card slot: http://elinux.org/Beagleboard:Updating_The_Software#Image_For_Booting_From_microSD



I ran into the same problem with my A5A’s. I finally ordered some BBB boards from Arrow and received A6A versions, those worked fine,
except the touch screen was jittery and overly sensitive. Plugging in a USB mouse solved the jittery cursor at the expense of
the loss of the touch screen. The 7" displays worked, but the 4.3" did not.


Thanks a lot, Hieu.

I can’t assure 100% but it seems that you were right. I have cut the problematic pins on the connector and now it is working fine. I’ve booted 8 times without problems.

Thanks again!