I2S Microphone in Beaglebone AI

Hello I am trying to check if a Beaglebone AI is getting correctly I2S from a TIDA-1454 so if I try to arecord test.wav I get:

debian@beaglebone:/etc$ arecord --device=“hw:1,0” -d 20 -f S16_LE test.wav
pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave arecord:
main:828: audio open error: No such file or directory

The card is detected since i get this output from arecord -l:

**** List of CAPTURE Hardware Devices ****
card 1: PCM5102a [PCM5102a], device 0: davinci-mcasp.0-pcm5102a-hifi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

or arecord -L:

> debian@beaglebone:/var/lib/cloud9$ arecord -L
null
    Discard all samples (playback) or generate zero samples (capture)
onboard
onboard_capture_left
onboard_playback_left
onboard_capture_right
onboard_playback_right
plug_onboard_capture_left
plug_onboard_playback_left
default
sysdefault:CARD=PCM5102a
    PCM5102a,
    Default Audio Device
dmix:CARD=PCM5102a,DEV=0
    PCM5102a,
    Direct sample mixing device
dsnoop:CARD=PCM5102a,DEV=0
    PCM5102a,
    Direct sample snooping device
hw:CARD=PCM5102a,DEV=0
    PCM5102a,
    Direct hardware device without any conversions
plughw:CARD=PCM5102a,DEV=0
    PCM5102a,
    Hardware device with all software conversions

and ALSA configuration:

pcm.onboard{
type hw
card 0
}
ctl.onboard {
type hw
card 0
}

### Dsnoop splited channels
pcm.onboard_capture_left {
     type dsnoop
     ipc_key 32
     slave {
         pcm "onboard"
         channels 2
	 rate 48000
    	 format S32_LE
     }
     bindings.0  0
}
pcm.onboard_playback_left {
     type dmix
     ipc_key 33
     slave {
         pcm "onboard"
         channels 2
     }
     bindings.0  0
}


pcm.onboard_capture_right {
     type dsnoop
     ipc_key 32
     slave {
         pcm "onboard"
         channels 2
	 rate 48000
	 format S32_LE
     }
     bindings.0  1
}
pcm.onboard_playback_right {
     type dmix
     ipc_key 33
     slave {
         pcm "onboard"
         channels 2
     }
     bindings.0  1
}


### PLUGS ##
### used with darkice
### device = plug:plug_onboard_left
pcm.plug_onboard_capture_left{
        type plug
        slave.pcm "onboard_capture_left"
}
pcm.plug_onboard_playback_left{
        type plug
        slave.pcm "onboard_playback_left"
}

pcm.!default {
    type asym
    playback.pcm "plug_onboard_playback_left"
    capture.pcm "plug_onboard_capture_left"
}

So what can it be the problem?