Incorrect device overlay selected during boot


My BBB stack has a 4.3" LCD cape – powerup diagnostics (dmesg) indicated the cape was found OK & brightness worked Ok. I was unable to view (startup) text on the display. (Ver 4.4.1-bone11). After a few days of debug, I found that the MuxPins were not properly updated and were still accessing HDMI (not modified as expected). I added an ‘echo’ into /uEnv.txt & discovered that the ‘overlay file’ was not right - it was the default chosen at power-up.

/boot/uEnv.txt has the lines (amongst others)

Disable: HDMI

/uEnv.txt was modified - fdtfile was replaced by dtb

#loadxfdt=load mmc 0:1 ${fdtaddr} /boot/dtbs/${uname_r}/${fdtfile}
loadxfdt=load mmc 0:1 ${fdtaddr} /boot/dtbs/${uname_r}/${dtb}

Possibly modifying fdtfile is the appropriate method – Is there a better solution?


Yeah, you’re modifying the wrong file.

debian@beaglebone:~/nfs$ cat /boot/uEnv.txt


##BeagleBone Black/Green dtb’s for v4.1.x (BeagleBone White just works…)

##BeagleBone Black: HDMI (Audio/Video) disabled:

. . .

dtb=am335x-boneblack-emmc-overlay.dtb is the line you’re after, and it probably is proceeded by a pound( # ) symbol. So it’s commented out. SImply remove the # to uncomment, and then reboot the board.