installing libpruio-dev +

Hi, I am trying to install support to use the libpruio library(ies)
I have tried adding
deb Index of /debian unstable main
deb-src Index of /debian unstable main
deb http:/ jessie/
deb-src [trusted=yes] Index of /debian jessie/

both with and without [trusted=yes]
sudo apt-get install libpruio-dev
E: E: Unable to locate package libpruio-dev
I have installed the fbc compiler sucessfully but the attempts to progress further are stymied by the inability to run the cmakefbc tool.
Can anyone advise a workaround?
I am currently using the
debian 10 image but I can go back to debian 9 or even debian 8.
Forgive me I know what kind of effort it is to write one of these things and the documentation effort is wonderful but I stopped programming in basic in 1983 and among the cloud of programming dust it resides with cobol for me and that is not a pleasant memory. I am trying to use the C wrappers as I am reasonably conversant with C on a number of different platforms. Thanks in advance

1 Like

Never used this so keep that in mind. Did search the internet and found some stuff on github. It is missing the serious parts of the package.

What exactly are you trying to do with the board.

Several on this forum seem to be very knowledgeable about the BBB and might be able to point you in a better direction.

By the way, I had plenty of fun with GW basic and what ever the commodore basic was.

Have you tried just compiling from source. Its hosted on github at:

The main developers page is at:

I don’t think it was ever included by debian officially so you would need to find out from main dev if he host pre-built binaries somewhere.

As a totally different alternative, have you looked at the simppru project? Its basically a project to make programming the PRUs like an arduino-style syntax…has its pros/cons but for sure easier to get started than via assembly / c method.

It was there in Debian 9 at one time: debian-9-libpruio · master · / repos · GitLab

Not sure why it didn’t go into Buster or Bullseye. I think the kernel updates and inclusion of remoteproc might have gotten in the way. Shared memory is still very possible with remoteproc, as well as controlling the processor execution from userspace, but the details of doing so are different than with direct UIO.

This is just about the LKM module (libpruio-lkm). The other packages never found their way to main stream. This is still confusing users.

Basic is a proven and old programming language (older than C). The modern FreeBASIC dialect is not comparable with GW Basic.

The packages at http:/ are not maintained any more. They’re designed for Jessie (Debian8?) and the previous kernel.

Once you installed the FreeBASIC compiler, you can download/build/install the cmakefbc package from GIT repo source.