Installing nfs-common breaks important service startup at boot time...

I have noticed that installing the “nfs-common” Debian package (to get NFS client functionality) breaks startup of certain services upon boot. I believe that this started happening in late December/early January time frame. I tend to keep my system up to date via apt-get update;apt-get upgrade so I think that this is related to some updated packages rather than a specific image build. I have been able to reliably recreate the on all recent images including the 2016-01-17 image which I used for this report.

The symptom is that avahi-daemon and connman don’t start properly on boot. This seems to be related to systemd dependency problems. There are some Debian issues that describe something like this, but seem to have been resolved some time ago. For example:

I believe what is happening is that systemd is detecting some dependency problem and killing off some critical process (dbus?) that causes downstream services to fail to start. I can manually start connman from the console (sudo systemctl start connman) once logged in to the console.

Note that simply removing the “nfs-common” package doesn’t make this problem go away. The only way to get out of this is to reflash…or at least I don’t know how to back out of this any other way.

FWIW, I’ve attached a dmesg log, syslog, and the console log.

As I’m not currently using NFS client, this isn’t a terribly big deal for me at the moment. It did take some time to figure this out as I normally run some of my own scripts that install additional stuff on a new image. The loss of connectivity (due to connman not starting) was what eventually got my on this path of figuring out what was going on. Obviously, I’m now avoiding nfs-common!

If anyone knows about a fix for this…all the better. I wanted to at least report what I’ve found in case there are others that may be attempting to use the NFS client.


ba (37 KB)

I’ve run into this exact issue, too me a while to figure out it was just installing the nfs-common package. Does anyone have any info on this?


I ran into this as well…

I had a problem where using NFS would halt half way through the boot process. I managed to fix this by:

In /lib/systemd/system/connman.service, change the ExecStart line to this:

ExecStart=/usr/sbin/connman -n -I eth0 // Prevent connman from managing eth0

Not sure if this is the problem you are having, but this worked for me. If this works for you, you may have an issue with DNS and that needs another fix because connman is no longer managing eth0.


Hello, same problem here, installing nfs-common maybe created some loop in systemd dependencies, shutting down connman?

Sep 01 22:12:46 arm systemd[1]: Unit connman.service entered failed state.
Sep 01 22:12:47 arm systemd[1]: connman.service start request repeated too quickly, refusing to start.
Sep 01 22:12:47 arm systemd[1]: Failed to start Connection service.
Sep 01 22:12:47 arm systemd[1]: Unit connman.service entered failed state.

don’t know how to fix this… Everything was working before isntalling nfs-common.

Noong Huwebes, Agosto 25, 2016 ng 5:44:02 PM UTC+2, si john3909 ay sumulat:

Ok, It seems that updating systemd (sudo apt-get install systemd) solved the issue for me.