Installing phpmyadmin on Debian version 2014-05-14 - Help

I am struggling accessing phpmyadmin. I have installed the package as well as created a symlink in /var/www but I get an error each time I go to http://ip-address/phpmyadmin. Any tips or tricks I could use?

I’m not that expert, but the tips I could think to are:

  • have you already PHP and MySQL installed? (would be better from Debian repos)
  • which IP you used? I’d suggest to use localhost/
  • check your firewall settings to allow traffic on TCP 80 (standard websites (HTTP) port)
  • check that phpmyadmin is symlinked in the correct folder; if you symlinked to /var/www shouldn’t it be in the main webroot?

yeah, Apache doesn’t use port 80 on the BBB. Instead I tink it uses 8080, or perhaps 3000. So . .



That is, I mean to say, the default demo images are set up to have Node.js use port 80 ( for bonescript I presume ).

I looks like port 8080 did it! Is there a config file to change the port?

bonescript.socket requests port 80 from systemd:

so we had to move apache to 8080

so if you disable bonescript.socket you can move apache back.