Installing USB Wifi (Asus N10)

I tried to use an N10 also…fell all the way back to trying it on my laptop with Ubuntu 12.04.2 and it didn’t work so I returned it presuming it was DOA. When I say it didn’t work, I mean it didn’t reliably show up in lsusb on the laptop…typically I had to issue the lsusb just after it was inserted as it seemed to power-off after failing the firmware download. Also it wholeheartedly failed to work in a WinXP environment despite using the CD for drivers.

These are my notes (quite incomplete, but may contain a useful pointer for you) as I tried to get rtl8712u.bin:

  • I found that everything seems to indirectly indicate that this 8188su device is supposed to use a “8172 driver”
    This was probably the single most useful link…it gives info on Debian/Wheezy for rPi, but the key was noting where the .bin should go and how to get it.
  • opkg stuff via a tutorial on adafruit’s learning page (
    I’m guessing you’re already past this, but perhaps it’ll be useful for someone:

find/install the linux drivers for RealTek (rtl) network stuff

opkg update
opkg list linux-firmware-rt*

this may be updated…might want to look at if package below is not found

opkg install linux-firmware-rtl8192su

As my N10 device didn’t even work on a laptop reliably I bailed…might end up in the same boat though as I ordered an adapter through adafruit which uses the same RealTek device, but I’m crossing my fingers.