Interfacing with the LG LB043WQ1 LCD screen using the hy-research LCD expansion board

Hi guys,

I know there's a similar topic discussion in our mailing's archive but
it seems to me that there's still no solution to it. So I would like
to ask everyone here, who know the solution could you please to guide
me how to do it?
here's what happened... Few days ago I purchased 5 sets of BeagleBoard
RevC4 + 5 set of BeagleLCD2 Expansion Board 4.3inch from
SpecialComputing. I tried to download the sources + prebuiltimages
from 0xdroid and load to Beagleboard (
wiki/UsingPreBuiltImages), but with no luck in displaying it on the
LCD touchscreen at all. A very kind senior here (Dorian) has share me
some of his code to fix the problem, including some files in Kernel
and U-boot. I have recompile the Kernel.bin successfully without any
error, but still facing a number of errors from compiling U-boot.
Which is this error:

make[1]: Entering directory `/home/bryan/Programming/0xlab-kernel-u-
In file included from beagle.c:39:
beagle.h:26:26: error: asm/arch/dss.h: No such file or directory
make[1]: *** No rule to make target `.depend', needed by
`libbeagle.a'. Stop.
make[1]: Leaving directory `/home/bryan/Programming/0xlab-kernel-u-
make: *** [board/ti/beagle/libbeagle.a] Error 2

I have searched all over the 0xlab-kernel-u-boot folder for that
"dss.h" library file but couldn't locate it at all. I tried to google
it but still no hope to find it anywhere.

So is there any other way for me to get the LCD up and running with
BeagleBoard revC using 0xdroid images? Or could you kindly send me
the dss patch?

Thank you very much for your time and help!

Best Regards,

I attached the file dss.h that was in my uboot version in the directory
include/asm/arch. That's true - in the actual uboot repo this file is

dss.h (4.59 KB)