Intermittent problem with Ethernet connectivity - common to both Beaglebone and BBB

This intermittent problem appears to be common to both the Beaglebone and BBB. I have observed it on at least ten units of the Beaglebone and now on my first BBB.

Ethernet refuses to connect. I have tried restarting connman.service and software rebooting, neither fix the problem. The only way I can get out of this is by either cycling power or hitting the reset. I have tried multiple cables/routers, but the symptom keeps reoccurring. This problem only rarely happens, but as SD "file-systems" do not appear to take kindly to undisciplined shutdowns, I would prefer a more elegant solution. Any suggestions?

Best regards,


When you say refuses to connect, do you mean the lights don't light on
cable insert or that Linux doesn't request an IP from DHCP or what?

If the lights aren't lighting, most likely it's the PHY energy detect
mode as the root cause. I see this issue with some Netgear switches
and most consumer HP laptops if I plug a white bone into them after
it has booted.