Is gitlab broken, I cannot copy and paste into a file

For some reason it does not allow a copy/paste operation in order to enter content into a file. It spawns a web ide that does not work properly, no paste. Its a tiny file and really don’t see the point in pushing it up, just wanted something simple to use. Did I miss something?

I had the same issues using Edge on Windows; not possible for me to edit anything live,
so I just push to repo instead.

I am on Debian 12 and Ubuntu 22.04. I don’t have a windows box handy to test it so you just confirmed it is not platform specific. Might be tied to java.

I see it with VSCode web ide and Firefox (on x11) copy paste is very picky (middle click doesn’t work), got use to right click copy/paste now… Seems to be a permission issue with a clipboard… I stopped using Chrome a few months ago due to the ad-block changes coming down the pipe… While middle click worked in Chrome, still not a reason to go back.


Seems like stuff running java is becoming more unstable. CLion also has issues with copy and paste and that is standalone not a browser app. I am running wayland and firefox.