Is my BeagleBone Black busted?

I’m trying to flash a fresh image but after holding the user/boot button while connecting to USB, and watching the lights go through the boot sequence (all light up solid, then some begin to flash), the lights go into a flashing pattern that never stops, and my Mac shows no mention of the BeagleBone in the network adapters list.

The flashing pattern is like this:
The D2 LED (closest to the corner) repeats a pattern of flashing twice and pausing. And the D4 LED (2nd closest to the LAN jack) stays flickers but it’s very very dim.

I’m confident the USB cable I’m using is a data cable because it has a ferrite noise filter. On my macbook air I have to use an adapter because there’s no built-in USB type A, only USB type C, so to rule out the adapter as a possible problem, I tried connecting with my iMac built-in USB type A port, but I got the same result.

Is my BeagleBone busted?

1 Like

That’s a normal boot process…

What image are you trying to flash (file name?), all the flashing scripts use a Cylon (Battle Star Galactic) pattern…


1 Like

from - Page not found

Is this the wrong image?

1 Like

That image is not an “eMMC Flasher”…

This is the image that will Flash the eMMC:

If your up to it, change this one file in the current image:



Thank you. I decided to just flash the image that you linked me to, it didn’t take long. So I think the flashing process worked, because this time I saw the Cylon light pattern, and then it stopped and all four lights went out, as the docs describe. So I pulled power, removed the SD card, and tried to connect on my mac, but the network adapters still show this:
Screen Shot 2021-04-29 at 2.25.18 PM

And trying to reach either or doesn’t work. Am I doing something wrong?

Hi @robtacular oh! Which version of macOS?

I’m pretty sure it was a bug we already fixed after that release… Apple nuked the cdc driver we used, but the ncm driver works that we switched to.

Sorry, time to re-flash again…

But macOS’s usb should work!


That worked! Thank you!

To answer your question, I’m on v11.0.1, Big Sur, and it’s the 2021 macbook air with the M1 chip.

Another good reason, besides #gsoc, to pin a new latest-image?

I recently purchased a MBP Apple Silicon and I followed this thread because the drivers do not work on ARM. I was able to see my BBB in my network connections but only with a self assigned IP, did you have this issue?

Hi @Daniel_Johnson , i only have intel Mac’s… the ncm driver should be enabled, feel free to test the latest Debian 10.x snapshot from a few days ago:


Thanks for the fast response! What’s happened since I’ve posted is that yes, the ncn driver on the latest image works for passing through the internet on USB. Each time I reboot I have to run dhclient before the internet functions. I can reach the internet and reach the cloud9 IDE from my host browser. I cannot, however, reach the actual BBB interface. So:
Internet over USB works
cloud9 interface is reachable
BBB interface is not reachable

Sadly, each OS, WIndows/Mac/Linux has unique way to configure the connections. From the USB side, we really can’t detect what OS you are running…

we have a few known os scripts here:

The mac ics might work for you:


One thing that confuses me is the difference between USB0 and USB1 as network interfaces. If I can reach the ip on USB1 (cloud9) but not (USB0), do I have my USB ports backwards?

By default:

usb0 - RNDIS - Windows/Linux :
usb1 - NCM   - Mac/Linux    :

So if your on Mac, swap all mentions of for


I think I was confused by an old tutorial. I am able to access everything now.

Years ago, we recommend HoRNDIS on mac, which used usb0/rndis interface over… so lots of old info. :wink: