Issue with P8, P9 Connectors not fitting on the BeagleBoneBlack (BBB) PCB

I hope someone can help with this.

I am currently getting some BBB PCBs manufactured. I have used the gerber data and BoM supplied but the PCB manufacturer is reporting an issue with the specified connectors not fitting because the PCB hole size is too small to take the pins.

The connector specified is: SSHS-123-D-02-GT-LF which has recommended hole size of 0.040 (1.2mm)

The PCB manufacturer is telling that the hole size in the drill file is: T04 Holesize 4. = 30.000000 Tolerance = +3.000000/-3.000000 PLATED MILS Quantity = 96

The data I have sent to them is from the file:

I am unsure what has happened here. Obviously these boards can be manufactured with the data.

I’d be grateful of any input and also if anyone can specify a connector that will fit holes of that size?

Many Thanks.

We don’t have any issues. We do look for a tight fit to prevent moving during the soldering process. We have used these same connectors for a very long time now without issue.

Which PCB files did you use?


Thank you for the speedy response Gerald.

The PCB files used were those contained in

Is it likely the holes were deliberately under-sized to the datasheet to give the tight fit you mention.

I am yet to see the problem physically for myself. The PCB supplier is sending the board to me so I can assess.

We did tighten them up along time ago, so that is most likely the issue they think they have.


Thank you Gerald. I will confirm if that is the case when I see the sample.

I can now confirm that my PCB supplier has now successfully fitted connectors P8, P8 and I have taken delivery of my first-off sample.
Gerald, are you able to point me to some instructions on how I get my “virgin” beagleboardblack up and running?
I have tried using an SD card with a known good android image but this does not work, the error I get from hyperterminal is:

U-Boot SPL 2011.09 (Nov 27 2013 - 10:43:10)

Chipsee AM335x EVM Board

Incorrect magic number in EEPROM

read_eeprom() failure. continuing with ddr3


mmc_send_cmd: timedout waiting for cmddis!

** Can’t read from device 0 **

spl: fat register err - -1

ERROR ### Please RESET the board

I’m not surprised that it doesn’t yet work because there must be some programming/setup to be done on the board itself before it will operate and this hasn’t yet been done.

I think I may have to program the E2…?

Could you help me with that procedure please?

Well. Uh. I have no idea what your design looks like. But, the code you are using looks for the EEPROM. Do you have one? If you do. is it programmed?


As long as it's 100% compatible with the beaglebone black, including
the on-board eeprom, memory, 1Ghz, etc.

eeprom: Make sure the write protect is off and boot with this image.


Thank you for the replies.

I would like to use my version of beagle without eMMC fitted. Could you confirm if this is possible?

In our application we would always boot from SD card so we have created our version of beagle with eMMC IC not fitted.

Is this it feasible to operate it in this way?

My design is a cut-down version of the BBB without HDMI IC fitted and without eMMC IC fitted.

I want to get my new BBB booting off the SD card. Is it essential to have the eMMC IC fitted or can the system be made to run without eMMC?

My design is a cut down version of BBB. The HDMI IC is not fitted and the eMMC is not fitted.

Will the BBB boot from SD card without the eMMC IC fitted? Or is the eMMC essential to the operation even when booting from Sd card?

Did you look at the System Reference Manual? Yes, it can boot from the SD if you remove the eMMC.


That should be fine.. Here's the init script i use to flash the eMMC,
notice how it programs the eeprom first before calling the eMMC
flasher script at the bottom.. So in the end it'll fail, but the
eeprom will be programmed with the beaglebone black eeprom..

Then you can go move on to your own images.


Thank you very much, I’ll check that out.

Hi Robert,

Here are the comments from our Android guy:

I’ve tried running the script using bootcmd in uEnv.txt, however I cannot run the script as u-boot does not get to the stage where it reads uEnv.txt.

Do you have any other suggestions for running the script?

Ah.. use the image i previously linked to.. The script was just for reference.