Issues with autostarting services in Debian

I am using my beaglebone black to run Octoprint for my printer. Its a new RevC with the MachineKit Image from and I followed the basic raspbian install instructions for getting OctoPrint installed which worked fine. I also installed X11vnc and mjpg-streamer. All of these work fine with started manually over ssh. The issue cosmes when I try to get any of these services to autostart on boot.

for Octoprint followed these instructions:

Automatic start up

Copy the script files to their respective folders and make the init script executable:

sudo cp scripts/octoprint.init /etc/init.d/octoprint
sudo chmod +x /etc/init.d/octoprint
sudo cp scripts/octoprint.default /etc/default/octoprint

Then add the script to autostart using sudo update-rc.d octoprint defaults.

I also tried running this:

create run-octoprint

cat > ~/run-octoprint <<EOT


cd /home/octo/octoprint/OctoPrint

. …/virtenv/bin/activate



chmod +x ~/run-octoprint

  • Add the following to /etc/rc.local

#run octoprint as octo user

( su -c /home/octo/run-octoprint octo ) &

For x11vnc I installed through apt-get and added another script to init.d for vnc to start the server, as well as trying to add to rc.local and setting up a .conf script in init.

and I never got to mjpg-streamer.

anyone have any ideas.