Issues with Beagleplay serial logs in minicom

While accessing the serial logs for BeaglePlay via minicom, it seems like they shrink to 1/4th of top left region (please refer the attached screenshot). Is there any minicom setting / board setting that I maybe missing to have the logs show up in full screen?

Here I have opened a file using vim just to show the issue I am facing wrt viewing serial logs

EDIT 1: It seems like to reproduce the issue one has to open vi / vim / nano (basically any text editor?).

This is a general tty issue. It is likely that minicom is reporting itself to be a certain type of terminal and therefore a certain number of rows and columns.

You can use a tool like stty to set the number of rows and columns in a terminal session. In the past, I’ve seen a number of useful utilities to resize the terminal session, including resize from xterm sources/package that might have some influence over minicom.

An Arch Linux wiki page that seems to capture my same understanding (Working with the serial console - ArchWiki):

Resizing a terminal

Unlike ssh, serial connections do not have a mechanism to transfer something like SIGWINCH when a terminal is resized. This can cause weird problems with some full-screen programs (e.g. less) when you resize your terminal emulator’s window.

Resizing the terminal via stty is a workaround:

$ stty rows lines cols columns

However, this requires you to manually input the proper geometry. The following methods should be simpler.

  1. There is a lesser-known utility called resize, shipped with xterm, that can solve this problem. Invoke it without parameters after you resize the terminal emulator’s window:

$ resize

This can be annoying and the best way to avoid it is to use an ssh terminal if you have networking.

As @jkridner has linked, to solve this in minicom (any serial console?) is to use the stty command to set the terminal window size. However this is not remembered between reboots and if you change the window size you will need to issue the stty command again to set the new size.

The resize command comes from the XTerm package, so unless you have X installed on your target not a viable option.