Issues with beagleV

Help me setting up wifi

For the out of box yocto take look at: Quick Start — BeagleBoard Documentation


I booted with Ubuntu latest version by beagle and tried all ways but having issue


@Subhajji_Suhas , do you have an antenna and/or have you messed w/ wpa_supplicant in the /etc/ file?

In the /etc/wpa_supplicant/ files are a list of other files. If you search through them, there may be some wpa_supplicant-wlan0.conf or something like that idea to handle WiFi.


i tried with all but the BBV is unable to scan the devices from both bluetooth and wifi
i tried with connmanctl and nmcli

FYI, I’ve not been able to get wifi or eth0 to work on any of the builds under xuantie-ubuntu, however, the xuantie-yocto build has working wifi and eth0.

WiFi and Ethernet only work on the 1.1.2 branch: Files · beaglev-1.1.2 · BeagleV-Ahead / xuantie-ubuntu · GitLab

Mainline, Ethernet is getting closer, still need tweaks to the clk framework to enable the phy…


thanks Robert, that worked.

Thank you will check it out revert backe to you

help me setting up wifi on 1.1.2 branch xuantie ubuntu
i need complete commands

Edit wpa_supplicant-wlan0.conf

sudo nano /etc/wpa_supplicant/wpa_supplicant-wlan0.conf

Then run:

sudo wpa_cli -i wlan0 reconfigure


1 Like