Issues with Booting Beaglboard xM using Angstrom Image

First of all, I am new to linux and the beagleboard so please excuse
me if my questions are less than scholarly.
I am having a few issues that I am attempting to resolve right now so
that I can get up and running on a project that I am doing. First off:

I am using minicom from ubuntu 10.10 to interact with the BB.
I have used the angstrom-distro .org how to video to get angstrom
running. (I think this video will not work for the xm but I am not
I have used this tutorial also:
The original angstrom image that came with the XM works flawlessly.
I have also used two angstrom images. One heavier from angstrom- and one that was created by narcissus.
Card formatting seems to be what it is supposed to be. A 100Mb fat32
partition with the rest being ext2 or ext3 by cylinders.

1) My first problem is that I can't get my own SD card images to boot
on start up. The original angstrom image works great and if I
interrupt the boot process and switch the SD cards to my angstrom
image, it works.
When it is not working, all I see in minicom are some garbage
character when I reset the board. Clearly, I am having an issue with
getting it to boot and not the image I have.

Minicom garbage:

Welcome to minicom 2.4

Compiled on Jun 3 2010, 13:48:00.
Port /dev/ttyUSB0

Press CTRL-A Z for help on special


I have tried copying the boot files from the included angstrom image
to my card. Same issue. I know I need the correct files inside my boot
partition but I can't seem to get it right.

Is there some formatting of the OMAP that I have to do to get it to
work correctly? At the end of the video tutorial I did, one is
requested to mess around with those setting which I did do but they
might not apply to the xm. When I did use that tutorial, the boot
process did not give me garbage but instead went looking for non-
existant NAND memory. Can I change that boot process to make it work?
This was by far as close as I got to making it work.

Basically, I am open to try anything.

My second problem is probably much more trivial. When I use opkg
install <pkg>, it installs the pkg to my ram no matter what I do.
Obviously, I would like for it to install to my SD card so I have some
disk space to work with and more importantly, so it is not volatile. I
have tried messing around with commands but I can't figure it out.

Any help would be greatly appreciated!

Thank you,


I had your problem when partitioning an microSDHC card. So I understand the frustration.

I downloaded the script you mentioned and it is using sfdisk. I don't believe it is using sfdisk correctly.

Robert Nelson has built a really great script for partitioning sd cards that you might be able to add to the script. To explain a bit:

The version of fdisk that your host system has might be from the util-linux-ng-2.18 package. In the 2.18 version, fdisk doesn't default to DOS-style partitioning. It needs to. You have to specify DOS-style partitioning as a command line option, and you must also specify the units required for the partitioning action, because you need units of cylinders and the default is units of sectors.

Mr. Nelson's script is util-linux-ng version 2.18 aware, and uses fdisk rather than sfdisk and with the right parameters. You can get his script from his git repository. The only problem here is, his script is focused on installing a Ubuntu image on the SD card, and you want an angstrom image. But you can hack out just the code needed to partition and format the sdcard, and transplant it to the script.

You can get his script by doing a git clone of his git repository:

git clone

Look inside the omap-image-builder directory that results, and search for the script.

If I have time in the next couple of weeks I will be happy to sort of merge these two scripts together and test the result. Right now, however, I'm hot on the trail of turning my Beagleboard xM into a media server for my wife. (And writing this email is a bit of yak shaving.)

Good luck

Bob Cochran