java couldn't run on debian

Java couldn’t run on debian
I typed “java -version” and got "-bash : permission denied " .Coulld somebody help me ?

It runs just fine if you install it correctly.

Care to go into more details of how you installed it?


Looks OK to me.

$ java -version

java version “1.7.0_25”
OpenJDK Runtime Environment (IcedTea 2.3.10) (7u25-2.3.10-1~deb7u1)
OpenJDK Zero VM (build 22.0-b10, mixed mode)

Compiles and runs “Hello world”.

export PATH=$PATH:/java/ejre/bin
export JAVA_HOME=/java/ejre

Okay so we can infer you are using oracle’s ejre… If you really want help and not just waste time, it actually helps to tell us what version you downloaded and installed.

I’m using java ejre version 7u51.


BTW, please see this link for helpful hints on asking questions:


Look at all the versions oracle has:

You need to state "exactly" which version you downloaded.


Thank you!

I have the same problem. I have already installed java in Amstrong with ejre-7u55-fcs-b13-linux-arm-vfp-sflt-server_headless-17_mar_2014.tar.gz ( Headless - Server Compiler EABI, VFP, HardFP ABI, Little Endian) and it worked.

Now I got the last version of Debian (BBB-eMMC-flasher-ubuntu-13.04-2013-10-08), but it does not work.

The error I get is: -bash: /usr/java/ejre1.7.0_55/bin/java: No such file or directory

even if i am sure that it is there.

my system (uname -a):
Linux arm 3.8.13-bone51 #1 SMP Thu May 15 18:33:59 UTC 2014 armv7l GNU/Linux

I tried some other installation files. Finally it worked! I used the installation files with hard floating point.