Kernel 4.1.9 overlays not working

Hello there,
I have installed latest console version of Debian from Its uses kernel version 4.1.9:

Linux beaglebone 4.1.9-ti-r20 #1 SMP PREEMPT Fri Oct 2 05:35:56 UTC 2015 armv7l GNU/Linux

I was trying to load BB-UART5 overlay but I failed. I also dont see any overlays loaded I thought I would, like eMMC:

root@beaglebone:/sys/devices/platform/bone_capemgr# cat slots 0: PF---- -1 1: PF---- -1 2: PF---- -1 3: PF---- -1

When I tried to load the tree i got:

[ 3013.532495] bone_capemgr bone_capemgr: part_number 'BB-UART5', version 'N/A' [ 3013.532543] bone_capemgr bone_capemgr: slot #4: override [ 3013.532561] bone_capemgr bone_capemgr: Using override eeprom data at slot 4 [ 3013.532579] bone_capemgr bone_capemgr: slot #4: 'Override Board Name,00A0,Override Manuf,BB-UART5' [ 3013.533110] __of_adjust_tree_phandle_references: Could not find target property 'fixup' @/__local_fixups__ [ 3013.548518] bone_capemgr bone_capemgr: slot #4: Failed to resolve tree

And I have compiled the tds before and put the dtbo in /lib/firmware/

Has anything changed in the new kernel regarding dts loading and general usage?
I would apreciate all help regarding this topic!

Am not sure: Did you compile dts with the patched version of dtc?


I used dtc in version 1.4.0 i believe.

To make overlays build properly, you need a special version of dtc
found at [1] further details see [2]



I will try this out, thank you.

W dniu 2015-10-12 o 11:58, 'Andreas Müller' via BeagleBoard pisze:

Im sorry but I cant find any source on how to install the dtc compiller after I have downloaed it from

W dniu 2015-10-12 o 11:58, 'Andreas Müller' via BeagleBoard pisze:

I think I managed to do everything, thank you.
There is still one thing that differs from version 3.8 kernel- I dont see either hdmi/emmc was disabled or not by looking at the slots. How can I check that?

W dniu 2015-10-12 o 11:58, 'Andreas Müller' via BeagleBoard pisze:

I am also getting the same error with 4.1.9-ti-r20, what exactly did you do to fix it?

Guys, please read the and /boot/uEnv.txt for examples on how
to disable the "hdmi/emmc"..

under: "BBB compatibility issues"

There are also other combinations listed in /boot/uEnv.txt


Hi, I have followed this link: beagleboard/ It doesnt say it in there, but after the steps with, you have to clone the directory and go into it for the next steps.

Thanks Robert,

I am simply trying to enable UART4 which I didn’t think needed anything disabling though?


in /boot/uEnv.txt


and reboot. :wink:

(this is assuming /lib/firmware/BB-UART4-00A0.dtbo is installed)


Thanks Robert,

BB-UART4-00A0.dtbo is present in /lib/firmware. I’ve not had an issue before but this is a freshly flashed Jessie BBB.

dmesg shows the following which is the same error as per the first post when echoing into the slots.

[ 4.968908] __of_adjust_tree_phandle_references: Could not find target property ‘fixup’ @/local_f

[ 4.979738] bone_capemgr bone_capemgr: slot #4: Failed to resolve tree
[ 4.987236] bone_capemgr bone_capemgr: loader: failed to load slot-4 BB-UART4:00A0 (prio 0)

That means you have the wrong dtc compiler..

You need to re-do step 2 & 3:

(i just updated the to make it more useful... (i think..))


Thanks Robert,

I’ve just reflashed it again with the latest Jessie image and will run through those steps.

One thing not 100% clear in the steps is the best location to get the latest (patched) DTC, there are many differing sources it seems!


I moved the "./" script right after the "check dtc" in
step 2... I'm hoping it should be more obvious to run it..



Yes that is much better thank you. Working well now :slight_smile:

Thank you very much,


Robert, I have the same question about the source of DTC 1.4.1-gXYZXYZXYZ - I installed the device-tree-overlay package into a new build (Linux beaglebone 4.1.10-bone-rt-r16 #1 Sun Oct 4 09:05:14 UTC 2015 armv7l GNU/Linux) and checked the version of dtc. It was v1.4.0. I tried running ./, but the version didn’t change. So, I cloned the git repository of the source at, did a make and make install. The version is still 1.4.0. The only reference Google has to the string in your readme (DTC 1.4.1-gXYZXYZXYZ) points to your readme.

Thank you

It's installed too:


If it doesn't work, your PATH is mangled..